LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-06-2003, 10:01 PM   #1
trpn
Member
 
Registered: Oct 2002
Posts: 31

Rep: Reputation: 15
setting time and date


I am sorry if this is a redundant question. I have searched the forums and tried to fix it with some suggestions that I have read but I cannot get this to work.

I am running debian sid. I am also dual booting with winxp. I wll try to lay out the problem clearly.

1. I start out in debian. My clocks were set fine until daylight savings occurs. So I had to adjust them since they didn't automatically. I changed it with the date command. "date mmddhhss" and it was fine.

2. I then went to the bios and it too was not changed. So I adjusted it in the bios.

3. booted into windows to play a game a couple days later and the hours were way off, about 5 hours. changed the time in windows.

4. when i went back to linux the hours were again off.

I have set the timezone to be Canada/EST, tried setting the time with "date", and then running hwclock --localtime --systohc, but that is not solving the problem.

any ideas?
 
Old 11-07-2003, 12:09 AM   #2
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
the date command using the complex format for date in "man date" (the man page).

date [MMDDhhmm[[CC]YY][.ss]]

like i set mine by doing date 110701082003

that means: Nov. 11 01:08(am implied) 2003

seconds default to 00

if the time is 1pm, date 110713082003 1pm = 13
 
Old 11-07-2003, 12:14 AM   #3
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1; SUSE 13.2
Posts: 626
Blog Entries: 1

Rep: Reputation: 50
Your Linux probably is treating the hardware (BIOS) clock as if it were set to GMT (Greenwich, England Mean Time). If that is the case, you need to tell your Linux to not do that.

If you have Mandrake 9.X, the tool you would use would be the Mandrake Control Center. Then, in the Mandrake Control Center date and time settings, you would select your time zone, at which time it will ask you if you want to make your BIOS clock be GMT, to which you would reply no.

I'm not certain about Linux distributions other than Mandrake, but suspect that the procedure would be similar.
 
Old 11-07-2003, 12:19 AM   #4
stuNNed
Member
 
Registered: Aug 2003
Distribution: Gentoo/Ubuntu
Posts: 134

Rep: Reputation: 15
if you're connected to the internet you can also use ntp to sync your system's time with that of a ntp server.
 
Old 11-07-2003, 12:20 AM   #5
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
yea, i use ntp only becuase i have to keep my remote machine and my server sync'd for nsupdate to work.
 
Old 11-07-2003, 07:48 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
That's bizarre. I run debian sid (funnily enough it's also dual-booted with XP) and I experienced that exact same problem. I seemed to go completely spastic for a while and could be off by several hours (not necessarily a nice round number either) over the course of a day. I thought my hardware clock had packed it in but if you had that problem too. I think it might have something to do with the date package in that case. Mine hadn't changed due to daylight saving so I had to change it manually. I think that's when all the toule started. I'd pretty much given up on it but your post made me look at the time again and it was EXACTLY one hour behind. It seemed to have stabilised. I changed it to the right time from the BIOS this time and I'll keep you posted on how accurate it stays.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setting time and date? maginotjr Slackware 7 06-28-2005 08:53 AM
Time & Date setting not sticking nathanv117 Linux - Newbie 3 04-10-2005 09:05 PM
setting date and time lynger Linux - Software 2 05-21-2004 12:10 AM
can't adjust the date/time setting fixxxer0101 Slackware 4 01-05-2004 08:23 PM
Setting Date and Time prich Linux - Newbie 3 12-16-2002 02:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration