-   Linux - Software (
-   -   Setting of view mode for Dolphin (

rrrm6ii1 11-12-2012 01:35 PM

Setting of view mode for Dolphin
Using Dolphin in plain user mode, no way of changing view mode from icons to details.
Using sudo Dolphin the option seems to work.
My system runs Kubuntu 10.
Any suggestion?

fakie_flip 11-12-2012 01:52 PM

Try changing the view modes with

Ctrl+1, Ctrl+2, Ctrl+3

If that still does not work, launch dolphin from a terminal. Try changing the view mode, and paste here the errors you get.

rrrm6ii1 11-14-2012 08:29 AM

thank you (this post could be a duplicate one)

Ctrl+1 etc have no effect nor raise an error
runnig Dolphin from terminal raises QPixmap::scaled:Pixmap is a null pixmap
Settings-Configure Dolphine raises QLayout: Cannot add null widget to QVBoxLayout/

Hope this can help.

fakie_flip 11-15-2012 08:00 AM

Is your dolphin up to date? Maybe there's a bug fix for it?

sudo apt-get update
sudo apt-get upgrade dolphin
or upgrade the entire system
sudo apt-get upgrade

Can you try removing it's configuration dot files or moving them so it starts with a default configuration and see if that fixes it?

Also which Kubuntu 10 are you using? There's 2 releases in 2010 and each year ever April and October. Use this command to check.

lsb_release -a

rrrm6ii1 11-15-2012 10:23 AM

Sorry, my distribution is based on Ubuntu 12.04.1 LTS

My Dolphin is updated

When I run dolphin using sudo dolphin, everything is OK

Don't know how to remove dot files (where could I find them ?)

Thank you

fakie_flip 11-15-2012 10:51 AM

Found it with Google:


rrrm6ii1 11-16-2012 09:49 AM

I did
$rm .kde/share/config/dolphinrc
I ran dolphin from the desktop icon : changing wiew mode is ok as soon as I don' t change directory
when I change directory dolphinrc is automatically recreated an the problem persist

fakie_flip 11-16-2012 02:54 PM

What is the permissions on that file? Maybe it needs write permission, and it's being created with a read-only umask.

ls -l ~/.kde/share/config/dolphinrc

Also try

sudo dpkg-reconfigure dolphin

frankbell 11-16-2012 07:52 PM

Also, do you have the same problem when you use Konqueror as a file manager?

I prefer Konqueror to Dolphin, but, when I saw your initial post, I tested in both Konqueror and Dolphin and was able to change the view settings in as user in both.

rrrm6ii1 11-18-2012 10:53 AM

thankyou to everyone
I reinstalled Kubuntu (10.20) and now dolphin works OK.
Issue closed

fakie_flip 11-19-2012 12:07 PM

I was going to ask if you'd post the contents of dolphinrc, but I see you reinstalled. Glad you got it working.

BTW, there's not a Kubuntu 10.20. Ubuntu release numbers get the numbers like this.

eg. Ubuntu 12.04

12= 2012 and 04 = month, April

Ubuntu and other varieties, Kubuntu, are released twice a year, every April and October, so you get a list like this.


You can see each year, an Ubuntu release comes out twice a year or every six months always on April and October though sometimes the release may be delayed if it's not ready by that time.

Another note: The difference between 12.04 and 12.04.1 is that a problem was discovered in 12.04, so Ubuntu maintainers fixed it and released the same 12.04 with the fix as 12.04.1

Some versions of Ubuntu/Kubuntu are known as LTS (Long Term Support) and will be supported for 4 years after their release.

If you're using an older version of Kubuntu just wanting to use KDE 3.5 instead of KDE 4.x, I suggest using this instead.

It is a port of KDE3.5 that gets updates and is still maintained.

Because KDE 3.5 is no longer supported, you will not get upgrades to it except maybe security backports in an LTS version of Kubuntu using it.

You can get a good distro that includes Trinity Desktop already in it. (Live CD has an installer and Fedora is a good newbie friendly distro like Ubuntu).

Or you can read on their website on how to install it into your own distro.

You should very rarely have to reinstall or reboot Linux to fix something. It's not windows, and by troubleshooting the problem, you gain skills and experience.


All times are GMT -5. The time now is 03:44 AM.