LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   set locale... (https://www.linuxquestions.org/questions/linux-software-2/set-locale-49283/)

pixelV 03-11-2003 11:09 AM

set locale...
 
My problem is reading and writing in russian.
I know that i have to set my locale and maybe something else to do...
Anybody who have alredy set his locale and now can read-write in russian or who knows how to do it, help please or give me usefull link.


:study: :study: :study:

Mara 03-11-2003 01:39 PM

I think it's
export LANG=ru_RU
Of course, you need Russian fonts. For X, it's somewhere in configuration programs (Mandrake Control Center etc), hard to say without knowing your distro.

pixelV 03-11-2003 01:58 PM

I have already try to set loacale to RU, but....
My distro is slack 8.1, but first i want to make bash understand RU

I know there are people who know how to make bash available read RU.
People, help me !

Mara 03-13-2003 12:52 PM

First you need Russian console fonts. Do you have them?

pixelV 03-14-2003 04:11 AM

I don't know, how i can know what fonts i have ?
And where i can find fonts and info how to install them ?

Mara 03-14-2003 04:35 PM

The settings are in /etc/sysconfig/i18n. Part of mine (for Polish):
SYSFONT=lat2u-16
SYSFONTACM=iso02
The fonts are in /usr/lib/kbd/consolefonts. You should have a big choice (I've got also Russian ones among many others).

pixelV 03-15-2003 03:58 AM

Hmmmm... You see, i don't have dir /usr/lib/kbd... but i have already installed kbd ( maybe bad version ? v1.06) And directory /etc/sysconfig... i don't have too :( It is very strange.

This is install progress (second time):

# ./configure
Configuring for DATADIR=/usr/share/kbd
Configuring for MANDIR=/usr/share/man
checking for gcc
gcc is /usr/bin/gcc
You have <locale.h>
You have <libintl.h> and gettext()
Assuming that you want to enable NLS support.
(Otherwise, edit defines.h and delete the line with ENABLE_NLS)
for i in src openvt po data; do (cd $i && make all); done

# make

make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/src'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/src'
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/po'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/po'
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/data'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/data'
Done. You can now do make install

# make install

for i in src openvt po; do (cd $i && make install); done
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/src'
install -d -m 755 /usr/bin /bin
install -s -m 0755 -o root dumpkeys loadkeys showkey setfont showfont setleds setmetamode kbd_mode chvt deallocvt psfxtable kbdrate fgconsole getkeycodes setkeycodes resizecons mapscrn loadunimap /usr/bin
install -s -m 0755 -o root screendump setlogcons setvesablank spawn_console spawn_login getunimap clrunimap outpsfheader /usr/bin
install -c -m 0755 -o root unicode_start unicode_stop /usr/bin
for i in psfaddtable psfgettable psfstriptable; do \
rm -f /usr/bin/$i; ln -s psfxtable /usr/bin/$i; \
done
rm -f /usr/bin/loadkeys
install -s -m 0755 -o root loadkeys /bin
You may also want to add psf.magic to /usr/lib/magic
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/src'
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'
install -d -m 755 /usr/bin
install -c openvt /usr/bin
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/po'
../mkinstalldirs /usr/share;
installing nl.gmo as /usr/share/locale/nl/LC_MESSAGES/kbd.mo
installing ru.gmo as /usr/share/locale/ru/LC_MESSAGES/kbd.mo
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/po'
cd data && make install
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/data'
install -d -m 755 /usr/share/kbd
install -d -m 755 /usr/share/kbd/consolefonts
install -m 644 consolefonts_Z/* /usr/share/kbd/consolefonts
install -d -m 755 /usr/share/kbd/consolefonts/partialfonts
install -m 644 partialfonts_Z/* /usr/share/kbd/consolefonts/partialfonts
install -d -m 755 /usr/share/kbd/consoletrans
install -m 644 consoletrans/* /usr/share/kbd/consoletrans
install -d -m 755 /usr/share/kbd/unimaps
install -m 644 unimaps/* /usr/share/kbd/unimaps
install -d -m 755 /usr/share/kbd/keymaps
install -d -m 755 /usr/share/kbd/keymaps/i386
install -d -m 755 /usr/share/kbd/keymaps/mac
for i in include sun amiga atari i386/azerty i386/dvorak i386/fgGIod i386/qwerty i386/qwertz i386/include mac/include mac/all; do \
install -d -m 755 /usr/share/kbd/keymaps/$i ;\
install -m 644 keymaps_Z/$i/* /usr/share/kbd/keymaps/$i ;\
done
rm -f /usr/share/man/man5/keytables.5
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/man'
cd openvt && make install-man
make[1]: Entering directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'
install -d -m 755 /usr/share/man/man1
install -c openvt.1 /usr/share/man/man1
make[1]: Leaving directory `/tmp/p-diffic-to-install/kbd-1.06/openvt'

Mara 03-15-2003 04:35 PM

You have /usr/share/kbd/consolefonts.

pixelV 03-16-2003 05:33 AM

OK, and what i have to do with this fonts ?

alt-8x16.gz iso03.16.gz lat7-14.psfu.gz
alt-8x8.gz iso04.08.gz lat7a-14.psfu.gz
altc-8x16.gz iso04.14.gz lat7a-16.psf.gz
aply16.psf.gz iso04.16.gz lat9-08.psf.gz
arm8.fnt.gz iso05.08.gz lat9-10.psf.gz
cp1250.psfu.gz iso05.14.gz lat9-12.psf.gz
cp850-8x14.psfu.gz iso05.16.gz lat9-14.psf.gz
cp850-8x16.psfu.gz iso06.08.gz lat9-16.psf.gz
cp850-8x8.psfu.gz iso06.14.gz lat9u-08.psfu.gz
cp857.08.gz iso06.16.gz lat9u-10.psfu.gz
cp857.14.gz iso07.14.gz lat9u-12.psfu.gz
cp857.16.gz iso07.16.gz lat9u-14.psfu.gz
cp865-8x14.psfu.gz iso07u-16.psfu.gz lat9u-16.psfu.gz
cp865-8x16.psfu.gz iso08.08.gz lat9v-08.psfu.gz
cp865-8x8.psfu.gz iso08.14.gz lat9v-10.psfu.gz
cp866-8x14.psf.gz iso08.16.gz lat9v-12.psfu.gz
cp866-8x16.psf.gz iso09.08.gz lat9v-14.psfu.gz
cp866-8x8.psf.gz iso09.14.gz lat9v-16.psfu.gz
cybercafe.fnt.gz iso09.16.gz lat9w-08.psfu.gz
Cyr_a8x14.psfu.gz iso10.08.gz lat9w-10.psfu.gz
Cyr_a8x16.psfu.gz iso10.14.gz lat9w-12.psfu.gz
Cyr_a8x8.psfu.gz iso10.16.gz lat9w-14.psfu.gz
cyr-sun16.psfu.gz koi8-14.psf.gz lat9w-16.psfu.gz
default8x16.psfu.gz koi8c-8x16.gz LatArCyrHeb-08.psfu.gz
default8x9.psfu.gz koi8r-8x14.gz LatArCyrHeb-14.psfu.gz
drdos8x14.psfu.gz koi8r-8x16.gz LatArCyrHeb-16.psfu.gz
drdos8x16.psfu.gz koi8r-8x8.gz LatArCyrHeb-16+.psfu.gz
drdos8x6.psfu.gz koi8r.8x8.psfu.gz LatArCyrHeb-19.psfu.gz
drdos8x8.psfu.gz koi8u_8x14.psfu.gz Mik_8x16.gz
ERRORS.gz koi8u_8x16.psfu.gz partialfonts
Goha-12.psfu.gz koi8u_8x8.psfu.gz README.12x22
Goha-14.psfu.gz lat0-08.psfu.gz README.Arabic
Goha-16.psfu.gz lat0-10.psfu.gz README.cp1250
GohaClassic-12.psfu.gz lat0-12.psfu.gz README.cybercafe
GohaClassic-14.psfu.gz lat0-14.psfu.gz README.Cyrillic
GohaClassic-16.psfu.gz lat0-16.psfu.gz README.drdos
gr737a-8x8.psfu.gz lat1-08.psfu.gz README.Ethiopic
gr737a-9x14.psfu.gz lat1-10.psfu.gz README.Greek
gr737a-9x16.psfu.gz lat1-12.psfu.gz README.Hebrew
gr737b-8x11.psfu.gz lat1-14.psfu.gz README.lat0
gr737b-9x16-medieval.psfu.gz lat1-16.psfu.gz README.lat7
gr737c-8x14.psfu.gz lat2-08.psfu.gz README.lat9
gr737c-8x16.psfu.gz lat2-10.psfu.gz README.psfu
gr737c-8x6.psfu.gz lat2-12.psfu.gz ruscii_8x16.psfu.gz
gr737c-8x7.psfu.gz lat2-14.psfu.gz ruscii_8x8.psfu.gz
gr737c-8x8.psfu.gz lat2-16.psfu.gz sun12x22.psfu.gz
gr737d-8x16.psfu.gz lat2a-16.psfu.gz t850b.fnt.gz
gr928-8x16-thin.psfu.gz lat4-08.psfu.gz tcvn8x16.psf.gz
gr928-9x14.psfu.gz lat4-10.psfu.gz t.fnt.gz
gr928-9x16.psfu.gz lat4-12.psfu.gz viscii10-8x16.psfu.gz
gr928a-8x14.psfu.gz lat4-14.psfu.gz

Mara 03-16-2003 12:14 PM

Look into /etc/rc.d/rc.sysinit. Search for SYSFONT. Change it to one of the fonts you have.
In older versions of Slack it worked:
setfont /usr/lib/kbd/consolefonts/Cyr_a8x16
mapscrn /usr/lib/kbd/consoletrans/koi2alt
You may try it, too.

pixelV 03-16-2003 12:48 PM

In /etc/rc.d i have rc.sysvinit And rc.sysinit i don't have. In rc.sysvinit I didn't find SYSFONT. As I said i don't have directory /usr/lib/kbd. I have dir /usr/share/kbd/. I tryed to set
setfont /usr/lib/kbd/consolefonts/Cyr_a8x16
But I have this:

root@xxx:/etc/rc.d# setfont /usr/share/kbd/consolefonts/Cyr_a8x1
Cyr_a8x14.psfu.gz Cyr_a8x16.psfu.gz
<font /usr/share/kbd/consolefonts/Cyr_a8x16.psfu.gz
putfont: PIO_FONT: Invalid argument
root@xxx:/etc/rc.d# setfont /usr/share/kbd/consolefonts/Cyr_a8x16.psfu
putfont: PIO_FONT: Invalid argument

When i type mapscrn /usr/share/kbd/consoletrans/koi2alt
command makes succesfully

And one more, before mapscrn and locale LANG=ru_RU i have this
total 91
-r-xr-xr-x 1 root root 74253 Jan 2 13:54 ??????? Windows-???????? ? Linux - ??????? ????????????.htm
dr-xr-xr-x 1 root root 2048 Jan 2 13:54 ??????? Windows-???????? ? Linux - ??????? ????????????_files
dr-xr-xr-x 1 root root 2048 Feb 21 17:56 PRIVAT
dr-xr-xr-x 1 root root 2048 Dec 23 22:34 Trinux
dr-xr-xr-x 1 root root 4096 Feb 17 15:13 UNIX
dr-xr-xr-x 1 root root 8192 Feb 6 21:50 Windows & DOS

( ? ---> is russian words )

And after:

????? 91
dr-xr-xr-x 1 root root 2048 ??? 21 17:56 PRIVAT
dr-xr-xr-x 1 root root 2048 ??? 23 22:34 Trinux
dr-xr-xr-x 1 root root 4096 ??? 17 15:13 UNIX
dr-xr-xr-x 1 root root 8192 ??? 6 21:50 Windows & DOS
dr-xr-xr-x 1 root root 2048 ??? 2 13:54 ??????? Windows-???????? ? Linux - ??????? ????????????_files
-r-xr-xr-x 1 root root 74253 ??? 2 13:54 ??????? Windows-???????? ? Linux - ??????? ????????????.htm

Maybe this info will be useful...

Mara 03-17-2003 02:33 PM

It looks everything's good but the font. Look into /etc/rc.d/rc.local and see if there's another run of 'setfont' (it does not always like to be run twice). If yes, change the name it uses with the one you tried.

pixelV 03-17-2003 02:42 PM

in rc.local i have only numLock set. Do you have more ideas ?
Maybe you know where i can get manuals ?

Mara 03-17-2003 03:54 PM

I'm thinking how many scripts you have in /etc/rc.d... In one of them there should be 'setfont' somewhere. The problem is that I don't have Slack 8.1 and I can't check...

turnip 03-17-2003 08:34 PM

grep -r -i setfont /etc/rc.d

should spit it out


All times are GMT -5. The time now is 04:50 AM.