-   Linux - Software (
-   -   set DISPLAY variable (

W1pEout[64] 01-07-2004 09:34 AM

set DISPLAY variable
Dunno if this fits into this forum.
Well, as I was browsing on the Inet, I found that ximiandotcom offered a free version of their Desktop 2.0 for SuSE 9.0 users.So I checked how to install it, and the instructions told me to simply type wget -q -O - http:(notallowedtopostaurlyet) |sh into a shell as the superuser.Well all the terminal gave me was this:

==> Autodetecting system type...
==> Checking $DISPLAY and X permissions...

The Ximian Desktop Installer is a graphical application, and
either you have no DISPLAY variable set or the root user does not
have permission to access your X server. Run 'xhost +localhost'
before becoming root, and make sure that the DISPLAY variable is
set correctly before running the go-ximian script.

Cleaning up temporary files... done.
Well how do I set this DISPLAY variable?I did what the program said and typed xhost +localhost but that didn't help either.Mybe you guys know how to fix this...

druuna 01-07-2004 09:37 AM

Like this:
export DISPLAY=<your.own.ip>:0.0

Type this in the console you are going to run the ximian thingie.

W1pEout[64] 01-07-2004 09:50 AM

the 192.168.2.xx thing or my "real" ip?
I tried both but neither worked, what could I have done wrong?
Still thanks for your help though!

druuna 01-07-2004 10:09 AM

It should be your LAN IP (the 192.168.2.xx you mention).

I guess you have started an (x)term, became root and try to start the ximian program.

After becomming root, in that (x)term, you should do the export DISPLAY=192.168.2.xx:0.0.
The xhost +192.168.2.xx should be done by the (regular) user that started the window manager.
Now you should be able to start the ximian program (as root, from the (x)term).

Hope this helps.

W1pEout[64] 01-07-2004 10:41 AM

Thx for the help!Worked, but I guess it's not free after all.... >_<

All times are GMT -5. The time now is 05:59 PM.