LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-02-2006, 01:39 PM   #1
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,119

Rep: Reputation: 46
service httpd fails


I'm using FC5 and when I try to start httpd it fails, but if I type it, it works, and if it fails, it actually tells my why, unlike when I try to start it with service.

How can I make it work with service? I want it to start on it's own at system startup.
 
Old 07-02-2006, 02:42 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Look at the /etc/init.d/httpd script and figure out exactly what command line options it is using with httpd. if it starts fine by hand then chances are that one of the pre-set options is the problem. You should also check the /var/log/httpd/error_log file to see if anythinh is reported there.
 
Old 07-02-2006, 02:53 PM   #3
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,402
Blog Entries: 1

Rep: Reputation: 64
From the Fedora Core 5 Linux Installation Notes:
Quote:
Originally Posted by http://stanton-finley.net/fedora_core_5_installation_notes.html
Go to "System" > "Administration" > "Security Level and Firewall". Provide your root password, click "ok" and on the "Firewall Options" tab make sure the check boxes next to "WWW (HTTP)" and "Secure WWW (HTTPS) are ticked. On the "SELinux" tab click the arrow on the left of "Modify SELinux Policy" and under (expanded) "HTTPD Service" make sure all the checkboxes are ticked except "Disable SELinux protection for httpd daemon" and "Disable SELinux protection for http suexec". (Please see http://fedora.redhat.com/docs/selinux-faq-fc5/ for important SELinux considerations.) Click "ok". Reboot your machine to enable the new SELinux settings.
 
Old 07-02-2006, 03:22 PM   #4
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,119

Original Poster
Rep: Reputation: 46
I did not install a GUI... so am I screwed? I'll look at those scripts though to see if there's anything obvious in there. And nothing was being produced in the error log (which suprisingly exists, since FC5 seems to lack logging of lot of stuff)
 
  


Reply

Tags
fails, httpd, start


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
service httpd status, results in httpd dead but subsys locked squadja Red Hat 2 09-11-2004 10:31 PM
httpd service stop fails, no pid, this after latest update squadja Red Hat 2 08-11-2004 02:29 PM
httpd as a service joshf Linux - Software 5 07-10-2003 07:54 AM
httpd service not starting... F$CK!!! xgtr Slackware 1 08-20-2002 03:13 PM
Using HTTPD Service skopje909 Linux - General 1 11-15-2001 03:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration