-   Linux - Software (
-   -   sendmail takes about 3 minutes to load (

cizzi 02-10-2007 02:21 PM

sendmail takes about 3 minutes to load
I did a fresh install of FC6 64-Bit Re-Spin version as my operating system on my new computer. Everything works great so far except when I added my hostname and local ip address to /etc/hosts. Now when I boot or start the sendmail service manually it takes several minutes for it to load. It loads successfully but I don't think its normal for it to take 3-5 minutes. This started happenning as soon as I added my hostname and ip address to the hosts file I believe. For now I just disable sendmail at boot time since I have no use for it right now but I would like to understand whats going on and eventually resolve the issue. I have running linux 5th edition but nothing really indicates a solution to my problem. Could anyone help?

What I added to /etc/hosts is this line linuxcore

linuxcore being my hostname that I set in network-config. If I type ping linuxcore it resolves correctly to my IP address assigned by my router. I obtained the ip by doing ifconfig and taking the ip address from the eth0 interface.


acid_kewpie 02-10-2007 04:34 PM

yeah it's always hosts file related, afaik it's a missing entry for localhost though, " localhost localhost.localdomain" is normally the first entry.

cizzi 02-12-2007 11:13 AM

problem solved
Someone in #fedora on helped me and it worked. the problem was that I had to add a period (.) after my hostname, I guess it was searching for a domain name and I didn't specify one. So the period tells it not to search for one I'm assuming.

All times are GMT -5. The time now is 01:29 AM.