LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Sendmail problem: sm-client permissions problem (https://www.linuxquestions.org/questions/linux-software-2/sendmail-problem-sm-client-permissions-problem-81401/)

d3funct 08-12-2003 05:00 PM

Sendmail problem: sm-client permissions problem
 
Hi,

I'm running RedHat 8, Kernel 2.4.20-13.8, and sendmail 8.12.8-5. The problem that I'm having is that when I run "mutt" and go to send an e-mail I get the following error :
"Output of the delivery process -- (all)
WARNING: RunAsGid for MSP ignored, check group ids (egid=500, want=51)"


and the error is Error sending message, child exited 71 (Operating system error.).

If I go to /var/spool/ (as root) and change the group owner of the "clientmqueue" directory from "smmsp" to the "jon" (my username), I can then send mail.

Now, I recently tried setting up q-mail, but didn't have time to finish. During that setup I had to mv /usr/lib/sendmail to /usr/lib/sendmail.old and /usr/sbin/sendmail to /usr/sbin/sendmail.old. I have since moved these back to the original "sendmail" files.

I am receiving e-mail just fine, and there are NO qmail processes running.
Why am I seeing this error and how do I fix it?


All times are GMT -5. The time now is 02:20 AM.