LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-05-2011, 12:51 AM   #1
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Rep: Reputation: 15
Sendmail is running but 25 is not listening


I have this issue in my Machine where the sendmail service is running and my port 25 is not listening ,some inputs from my serer
Code:
[root@xyz]# cat /etc/redhat-release 
Fedora Core release 4 (Stentz)
Code:
[root@xyz tmp]# ps -ef|grep sendmail
root     13082     1  0 12:12 ?        00:00:00 sendmail: Queue runner@01:00:00 for /var/spool/mqueue
smmsp    13089     1  0 12:12 ?        00:00:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
smmsp    13090 13089  0 12:12 ?        00:00:00 sendmail: ./p1547VmS005080 from queue       
root     13435  4667  0 12:14 pts/1    00:00:00 grep sendmail
Code:
[root@xyz tmp]# cat /etc/sysconfig/sendmail 
DAEMON=yes
QUEUE=1h
Code:
[root@xyz tmp]# netstat -nlpl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 127.0.0.1:20032             0.0.0.0:*                   LISTEN      2864/nvcmgr         
tcp        0      0 0.0.0.0:389                 0.0.0.0:*                   LISTEN      5587/slapd          
tcp        0      0 0.0.0.0:199                 0.0.0.0:*                   LISTEN      3768/snmpd          
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      2374/mysqld         
tcp        0      0 0.0.0.0:20031               0.0.0.0:*                   LISTEN      2952/nvnmgr         
tcp        0      0 :::389                      :::*                        LISTEN      5587/slapd          
tcp        0      0 :::22                       :::*                        LISTEN      2103/sshd           
udp        0      0 0.0.0.0:514                 0.0.0.0:*                               2025/syslogd        
udp        0      0 0.0.0.0:161                 0.0.0.0:*                               3768/snmpd          
udp        0      0 0.0.0.0:20031               0.0.0.0:*                               2952/nvnmgr         
udp        0      0 202.144.76.29:123           0.0.0.0:*                               3285/ntpd           
udp        0      0 127.0.0.1:123               0.0.0.0:*                               3285/ntpd           
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               3285/ntpd           
udp        0      0 :::123                      :::*                                    3285/ntpd
Code:
[root@xyz tmp]# service sendmail status
sendmail (pid 13090 13089 13082) is running...
 
Old 02-05-2011, 01:04 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
well this is the default config, you seldom want it doing anythign other than local mail services, so it doesn't listen. open /etc/mail/sendmail.mc and you'll find a daemon options like to comment out which is specifically telling it to only listen locally:

dnl # The following causes sendmail to only listen on the IPv4 loopback address
dnl # 127.0.0.1 and not on any other network devices. Remove the loopback
dnl # address restriction to accept email from the internet or intranet.
dnl #
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl
 
Old 02-05-2011, 01:16 AM   #3
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
well this is the default config, you seldom want it doing anythign other than local mail services, so it doesn't listen. open /etc/mail/sendmail.mc and you'll find a daemon options like to comment out which is specifically telling it to only listen locally:

dnl # The following causes sendmail to only listen on the IPv4 loopback address
dnl # 127.0.0.1 and not on any other network devices. Remove the loopback
dnl # address restriction to accept email from the internet or intranet.
dnl #
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl
I Did it but not solved the issue,and i my requirement is not to listen to looback only i need to add my server in a Relay and need to send alert over mail,i've similar boxes which i can see the port is listening locally and also to the relay server.i've done as you've asked
Code:
dnl # The following causes sendmail to only listen on the IPv4 loopback address
dnl # 127.0.0.1 and not on any other network devices. Remove the loopback
dnl # address restriction to accept email from the internet or intranet.
dnl #
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl
dnl #
 
Old 02-05-2011, 01:18 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
what have you fdone then? comment out the line and restart sendmail and it should, afair, listen on all interfaces.

Personally though, i'd drop in postfix as a nicer replacement.
 
Old 02-05-2011, 01:25 AM   #5
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
what have you fdone then? comment out the line and restart sendmail and it should, afair, listen on all interfaces.

Personally though, i'd drop in postfix as a nicer replacement.
As i said i did it ,but still nothing works ,the maillog has the following
[CODE][Feb 5 12:54:30 xyz sm-msp-queue[22901]: p14201Pf022047: to=root, ctladdr=root (0/0), delay=1+05:24:29, xdelay=00:00:00, mailer=relay, pri=3180283, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
/CODE]
 
Old 02-05-2011, 05:34 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
You said you'd done it, but showed code where it had not been done... what are we supposed to make of that? Now you have shown that you're not listening on port 25. show us all the code (not the comments), and that sendmail is running, and listening on the appropriate interfaces, i.e. "netstat -plnt" output.
 
Old 02-05-2011, 07:58 PM   #7
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
You said you'd done it, but showed code where it had not been done... what are we supposed to make of that? Now you have shown that you're not listening on port 25. show us all the code (not the comments), and that sendmail is running, and listening on the appropriate interfaces, i.e. "netstat -plnt" output.
What i meant is that i've tried both the option as it was not worked,so i reinstall the sendmail and it worked ,now the configuration is like
Code:
dnl #
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl
dnl #
and netsat now will be
Code:
netstat -plnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 127.0.0.1:20032             0.0.0.0:*                   LISTEN      2864/nvcmgr         
tcp        0      0 0.0.0.0:389                 0.0.0.0:*                   LISTEN      5587/slapd          
tcp        0      0 0.0.0.0:199                 0.0.0.0:*                   LISTEN      32384/snmpd         
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      2374/mysqld         
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      22355/sendmail: acc 
tcp        0      0 0.0.0.0:20031               0.0.0.0:*                   LISTEN      2952/nvnmgr         
tcp        0      0 :::389                      :::*                        LISTEN      5587/slapd          
tcp        0      0 :::22                       :::*                        LISTEN      2103/sshd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail not listening on any ports SorC Linux - Server 10 11-09-2011 10:10 AM
Sendmail and changing it's default listening port... darkarcon2015 Slackware 7 01-20-2005 11:17 PM
Sendmail not listening eggoz Linux - Software 6 09-06-2004 04:08 AM
Postfix running but not listening on 25 pnh73 Linux - Networking 1 05-27-2004 12:07 AM
sendmail listening on port 25 dskny Linux - Software 14 08-12-2003 06:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration