-   Linux - Software (
-   -   Segmentation Fault with browser open (

Bucolic Buffalo 01-18-2003 05:31 PM

Segmentation Fault with browser open
I'm a newbie, so be gentle. I am currently using Mandrake 9.0 with the Gnome desktop and Galeon browser. I experienced nearly the same thing in a previous install using the KDE desktop and Mozilla.

I was surfing in eBay, the computer listings, and at a point which seems to vary a little, I get this message in Gnome (no message in KDE, Mozilla just closes):
Application "/usr/bin/galeon-bin" (process 7454) has crashed due to a Fatal error. (Segmentation fault)

It will not let me send a bug report or go to a link describing the error. I have to close the window and Galeon closes.

I did a search here and Google without much success. Although a search of Segmentation error brings back like 165 pages of stuff. That's a bit much.

But both Gozilla and Galeon crash doing nearly the same thing. Is it a browser problem or a Linux problem? I ran the package update after the install, so I think I have the latest versions.


Bert 01-18-2003 05:40 PM

It's a browser problem.

Does it happen on the same page? If so, it might be a misconfigured plugin (especially the java plugin!).
If it's not that, did you have galeon ready installed or did you install it youself?
Is it version 1.2.6 or an older version? Upgrade it as older versions used to segfault lots.


Bucolic Buffalo 01-18-2003 07:53 PM

Hi Bert,

I am surfing the same area in eBay, hard drives section. Sometimes it crashes when I hit back, sometimes when I tell it to display ending today.

I have not added a Java plugin to Galeon. I have most things displaying from what I have seen, but perhaps it is not there.

Taking some advice from another thread which said it is easier on newbies if they install everything. So I did a new install on Mandrake 9.0 and selected everything except the server stuff. I then told it to do the automatic update. However Galeon is only version 1.2.5, so I expect that is what I need to do. Just have to figure out how to do that.

What's kind of frustrating is, I have played with computers since the TRS80 model I. Linux is new to me even thought I have toyed with a couple older versions over the years. Just never figured it out.

Thanks for the reply!:)

Bert 01-18-2003 09:46 PM

You should find a new version on their site:

and if you do:

whereis galeon

at the command line, it will tell you .. well .. where the base directory is. Have a look in there first to see if there's any notes. I would strongly suggest upgrading. Galeon is by far and away the best browser on the planet. I used to driticize it for instability. Then they fixed it.

As you know, there's always a learning curve. My own dad used to run a PDP-8 and worked with Roger Penrose (there's a good xscreensaver hack from him) but nowadays, Microsoft Windows 98 (with some GnuWin encouragement from your truly) is just fine for him.

So you're doing exceptionally well already.



moeminhtun 01-19-2003 10:51 AM

I'm currently encountering the same segmentation fault problem which is also know as signal 11. The mozilla and opera crashes, java crashes and gnome terminal crashes often, occuring the segmentation fault. In my case I'm sure that would be hardware or hardware configuration problem. (because I'm using the same redhat 8.0 at my office and it's very solid and no crashes.)
Check it out this website which is for segmentation fault problem. It is quite good.

Bert 01-19-2003 11:35 AM

I've seen Linux running rather on some very advanced Taiwanese laptops (which were also a bit too cheap) and XFree86 particularly didn't run well. WinXP kept crashing too.

So I'm not very familiar with signal 11. But hardware quality varies for sure.


moeminhtun 01-19-2003 01:14 PM

Ahh!! really? Last time, I saw Linux pre-installed Taiwanese labtops and I was thinking to get one because I had not seen any labtop which come with Linux pre-installed. Thank God I didn't buy it , if the one you are talking about is the same as the one I saw.

Bert 01-19-2003 04:22 PM

The one I saw was ... a clone I think maybe of a Compaq. Another one had the fingerprint ID key thing on it. Nice, but it didn't work in Linux as the driver was proprietary.

Of course Taiwan make some cheap products, but they're riding the "low cost leading edge" (and why not!!!) so I don't think they're made for reliability.

I've owned three laptops, all IBM's and I've dropped each of them at some point. Dropping them doesn't seem to bother them as they're built like tanks!

My hint for buying an IBM laptop is buy it in Japan. IBM's not a prestige brand there so IBM Japan sells high spec laptops relatively cheaply. I got a Celeron CDR/W iSeries there two years ago when those weren't available in the UK.


All times are GMT -5. The time now is 09:37 PM.