LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Segmentation fault loading plugin (gstreamer) (https://www.linuxquestions.org/questions/linux-software-2/segmentation-fault-loading-plugin-gstreamer-260615/)

Saur2004 11-29-2004 03:55 PM

Segmentation fault loading plugin (gstreamer)
 
I had massive problems running xine on my Fedora Core 3 installation. I tried using one of the latest builds at 'cambuca.ldhs.cetuc.puc-rio.br/xine/' That version locked my entire system up regularly. (My system would start slowing down then the mouse would not move at all. I could not ctrl-alt-F# to a command line log in and I couldnt even ssh into the box. The harddrive light would be dead on and the only thing I could do is reset button)

So I 'rpm -e' the ui and lib of that version.

Then I tried downloading the sources and ./configure; make install
the lib and ui for xine. Everything seemed to go well but once I rebooted the system after that I started to get ""eggcups" aborted unexpectedly" and errors that I cant remember about the volume system. And I dont have the volume control icon on my control panel.

I was able to fix the eggcups problem after finding a post somewhere that says a /etc/cron.daily/prelink seems to fix it. But I still have volume control problems.

I have since 'make uninstall' on both the lib and ui for xine. But I still have this volume control problem.

When I do a:

gnome-volume-control

I get:

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.8/libgstalsa.so

Please either:
- remove it and restart
- run with --gst-disable-segtrap and debug

When I add that option it just segmentation faults.

Any ideas on how to fix this short of yet another reinstall of the OS?

Ill say this much, Im not going to be using xine again any time soon.


All times are GMT -5. The time now is 04:15 PM.