LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2011, 11:50 AM   #1
boopathisivakumar
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 0
Question segmentation fault in arm edb9315a for helloworld.c application


i had added a hello world program object file in /tmp directory and cross compiled successfully but after porting completed a segmentation fault appeared while running that application!!!!!!!!!!!
am using arm9 edb9315 cirrus logic board....
give Ur ideas to run the application successfully..

this is my sample program
#include<stdio.h>
void main()
{
printf("hello world\n");
}
pls give the solution to run this program from the board................

Last edited by boopathisivakumar; 01-29-2011 at 11:52 AM.
 
Old 01-30-2011, 09:31 PM   #2
rahulkya
Member
 
Registered: Feb 2009
Location: New Delhi
Distribution: Linux mint,Ubuntu,Debian,RHEL 5,slackware 13.1, free BSD,solaris.
Posts: 186
Blog Entries: 3

Rep: Reputation: 33
try removing void then run the program...why r u running in /tmp ????
 
1 members found this post helpful.
Old 02-03-2011, 04:49 AM   #3
boopathisivakumar
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Original Poster
Rep: Reputation: 0
thank u rahulkya..
but i created new ramdisk with my application using build.sh script from cirruslogic 2.0.2(build version)..it was successfully ported..
 
Old 03-09-2011, 10:10 AM   #4
maplvig
LQ Newbie
 
Registered: Mar 2011
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by boopathisivakumar View Post
thank u rahulkya..
but i created new ramdisk with my application using build.sh script from cirruslogic 2.0.2(build version)..it was successfully ported..
Could you maybe elaborate a bit on how you made it work. I have the exact same problem on an other arm-linux board: simple hello world program cross compiles fine with "arm-softfloat-linux-gnu-gcc", but produces segmentation fault when run on target.

I was not able to find the build.sh script for your cirrus logic board.

thanks

*EDIT* I just solved the problem. Really simple and stupid. I used FileZilla to transfer the files and for som reason it transfers in ascii mode by default.

Last edited by maplvig; 03-09-2011 at 10:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiled OpenVPN returns a Segmentation Fault when runned on an ARM Board Berris.Oliver Linux - Networking 7 02-23-2012 11:06 AM
Error Segmentation fault when run encode with VP8 on QEMU for ARM linux hero132 Slackware 0 08-24-2010 11:03 PM
segmentation fault on arm linux golden_boy615 Programming 0 03-10-2009 02:56 PM
Cross-compiled wireless_tools_v29 caused segmentation fault on arm-platform mailerlee Linux - Wireless Networking 0 02-26-2008 05:01 AM
segmentation fault with my Gtk Application jaganmolleti Programming 1 03-18-2003 12:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration