LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-26-2019, 03:28 AM   #1
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Question Seconds in MATE panel clock causes system tray items to move.


Hi.

I allow seconds to show in the MATE 1.20.5 panel clock. This causes the items in the notification area to move a bit constantly as the seconds numbers change.

Can anyone figure this one out?

Thanks.
 
Old 10-26-2019, 05:21 AM   #2
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 4,955

Rep: Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830
What's the format defined for the display of the date/time? Do the seconds use/have a leading -0-?
 
Old 10-26-2019, 06:45 AM   #3
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Post

Quote:
Originally Posted by scasey View Post
What's the format defined for the display of the date/time? Do the seconds use/have a leading -0-?
Hi scasey. Here's a screenshot. It's using the 24h format.
Attached Thumbnails
Click image for larger version

Name:	2019-10-26_12-44.png
Views:	13
Size:	4.2 KB
ID:	31642  

Last edited by linustalman; 10-26-2019 at 09:15 AM. Reason: added 'It's using the 24h format.'
 
Old 10-26-2019, 07:15 PM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Linux Mint
Posts: 1,738

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
I'm using
Code:
<b>%a %d-%b  %R:%S  </b>
as the format for the mate panel clock and have never seen any movement of items in the notification area as a result of the seconds ticking away
 
Old 10-26-2019, 07:25 PM   #5
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 4,955

Rep: Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830
Quote:
Originally Posted by RockDoctor View Post
I'm using
Code:
<b>%a %d-%b  %R:%S  </b>
as the format for the mate panel clock and have never seen any movement of items in the notification area as a result of the seconds ticking away
Thank you. Thatís what I was asking the OP for in #2. OP?
 
Old 10-27-2019, 02:53 AM   #6
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by scasey View Post
Thank you. Thatís what I was asking the OP for in #2. OP?
I see, I misunderstood your question. Here it is:

Code:
%a %e %b %H:%M:%S
I want: DDD DOM MMM TIME (24h)

Last edited by linustalman; 10-27-2019 at 03:40 AM.
 
Old 10-27-2019, 04:32 AM   #7
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Post

Here is a gif. It's like this even after I deleted the clock (this also deleted the entry in dconf) and I just selected the seconds option by right clicking on the tray icon.

https://i.postimg.cc/G2rLpHFz/vokosc...7-09-30-13.gif
 
Old 10-27-2019, 05:33 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,942
Blog Entries: 9

Rep: Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230
So, the same thing happens every minute if you disable seconds, yes?
Have you tried using a monospaced font for the clock?
 
2 members found this post helpful.
Old 10-27-2019, 05:47 AM   #9
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by ondoho View Post
So, the same thing happens every minute if you disable seconds, yes?
Have you tried using a monospaced font for the clock?
When I disable seconds from the panel clock options - the clocks stays in 1 place.
How can I change the clock font?
 
Old 10-27-2019, 05:47 AM   #10
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Exclamation

BTW, I no longer see a 'clocks' entry to edit the clock format in dconf.
Attached Thumbnails
Click image for larger version

Name:	Windowshot_2019-10-27_09-49-03.png
Views:	8
Size:	28.7 KB
ID:	31665  
 
Old 10-27-2019, 06:26 AM   #11
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,942
Blog Entries: 9

Rep: Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230Reputation: 4230
Quote:
Originally Posted by linustalman View Post
When I disable seconds from the panel clock options - the clocks stays in 1 place.
Maybe it extends its maximum width with the seconds.
So you'd need to assign it a new width, wide enough to cover the whole date & time.
And no, I have no idea how to do that on MATE. Maybe you simply can't.

Have you tried a monospaced font?
 
2 members found this post helpful.
Old 10-27-2019, 07:48 AM   #12
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Post

Quote:
Originally Posted by ondoho View Post
Maybe it extends its maximum width with the seconds.
So you'd need to assign it a new width, wide enough to cover the whole date & time.
And no, I have no idea how to do that on MATE. Maybe you simply can't.

Have you tried a monospaced font?
Hi ondoho. Here's my font setup in Debian 10 (it's the default setting).
Attached Thumbnails
Click image for larger version

Name:	Windowshot_2019-10-27_12-47-28.png
Views:	13
Size:	61.3 KB
ID:	31667  
 
Old 10-27-2019, 10:00 AM   #13
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Exclamation

Quote:
Originally Posted by ondoho View Post
So, the same thing happens every minute if you disable seconds, yes? ...
Actually, I just noticed, the clock did indeed move as the minute changed (even without the seconds option) - it happened as 14:51 went to 14:52.
 
Old 10-27-2019, 11:59 AM   #14
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,102

Original Poster
Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Question

Is there at least a command to put the date before the month? e.g. 'Sun 27 Oct 16:58'?
 
Old 10-27-2019, 12:42 PM   #15
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 4,955

Rep: Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830Reputation: 1830
Quote:
Originally Posted by linustalman View Post
Is there at least a command to put the date before the month? e.g. 'Sun 27 Oct 16:58'?
Just need to change the sequence of the format
Code:
%a %b %e %H:%M:%S
man date for details of formats.

I'm running Cinnamon. The font seems to be monospace and I don't get any shifting when the numbers change. I think ondoho's right: The shifting is happening on your desktop because the font is a variable-width font.

I couldn't find where to change that on the panel or in the Calendar settings either (I'd like to have it a little larger), yet.

Edit: In "Panel Edit Mode" if I make the panel bigger an check the "let Cinnamon adjust size of text" I get bigger text...still not finding where to change the font on the panel or for the date/time, tho.

Last edited by scasey; 10-27-2019 at 12:53 PM.
 
  


Reply

Tags
clock, mate, moving, panel, seconds


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Plasma panel items moved, can't move them back L_Carver Linux Mint 3 12-30-2016 07:21 PM
[SOLVED] Solus - possible to move panel to bottom and single click to open items? linustalman Linux - Distributions 6 03-04-2016 02:15 PM
LXer: Ubuntu MATE 15.04 Arrives With MATE Desktop 1.8.2 and MATE Tweak LXer Syndicated Linux News 0 05-15-2015 09:30 AM
[SOLVED] "No system tray detected on this system" error on MATE desktop after nvidia graphics upgrade. lensilvan Slackware 14 07-23-2014 11:36 PM
Things for KDE system tray in gnome system tray Boffy Linux - General 3 09-17-2004 07:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration