LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-07-2009, 06:38 AM   #1
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Rep: Reputation: 15
Seamonkey fails to stay open.


Hi Everybody,

I have just upgraded my computer from Suse 10.2 to Suse 11.1. I normally use Seamonkey and Firefox as my web browsers. I still have my home directory.

After the install I Seamonkey was listed, but not installed. I used Yast to install it. When I click on Seamonkey the program opens briefly showing my homepage and then disappears.

Not sure why it is doing this. I wonder if it is something to do with the information held in my /home?

Any ideas suggestions would be of great help.

Regards

Nappy501
 
Old 07-07-2009, 10:49 PM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 71
Try starting it from a terminal window. It will print out some info, we can then try to figure out why it's crashing.
 
Old 07-08-2009, 03:52 AM   #3
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Uncle_Theodore View Post
Try starting it from a terminal window. It will print out some info, we can then try to figure out why it's crashing.
Yes, that would be useful. Right I tried opening it in a terminal and got this:
Code:
nappy@linux-5oez:~> seamonkey
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
/usr/bin/seamonkey: line 277: 19629 Segmentation fault      $AOSS $MOZ_PROGRAM $MOZ_LANG
Also I must own up, I have remembered. When I installed before in 2007, I didn't have Seamonkey, so I downloaded it and installed it. I don't know how as I think that is the only time I have managed to install a program using a terminal. After that I discovered yast, so that is how I normally install.

I think Seamonkey was installed on my home directory, which is still there after the install. Last night I deleted all the seamonkey I could find from my home directory and using yast and then rebooted my machine and installed Seamonkey using yast.

I tried opening in a terminal I presume that is what you meant and got the message above.

Regards
 
Old 07-08-2009, 08:44 AM   #4
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 518

Rep: Reputation: 278Reputation: 278Reputation: 278
Try launching Seamonkey as root - in a terminal, go "su -", enter your password, and then run the seamonkey command. If you get the same problem as root, that will rule out any problems with files in your user's $HOME.
 
Old 07-08-2009, 01:58 PM   #5
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Poprocks View Post
Try launching Seamonkey as root - in a terminal, go "su -", enter your password, and then run the seamonkey command. If you get the same problem as root, that will rule out any problems with files in your user's $HOME.
Well I never, I did the above and it opened. It is blank though no bookmarks, but I can live with that. How do I open it as me rather than as root?

Thank you in advance.

Regards

Nappy
 
Old 07-08-2009, 04:30 PM   #6
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by nappy501 View Post
Code:
nappy@linux-5oez:~> seamonkey
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
/usr/bin/seamonkey: line 277: 19629 Segmentation fault      $AOSS $MOZ_PROGRAM $MOZ_LANG
I have just put the first part of the message into Google and found this:

http://forums.opensuse.org/applicati...firefox-b.html

Does it mean it's not me?
 
Old 07-29-2009, 03:33 PM   #7
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Original Poster
Rep: Reputation: 15
I've given up!

Hi Everyone,

I didn't get this sorted out, so I have given up. I have installed Opera with Yast. I am hoping I like it.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Command to open file in SeaMonkey Composer Chriswaterguy Linux - Software 2 05-04-2009 03:12 AM
LXer: SeaMonkey 1.0.6 and SeaMonkey 1.1 Beta Released LXer Syndicated Linux News 0 11-09-2006 03:33 PM
How to make a shell stay open? TheSpork Linux - General 6 09-08-2004 10:07 PM
Djvu wont stay Open hhegab Linux - Software 0 05-29-2004 09:13 AM
gkrellm without having Konsole stay open? /home/kyle Linux - Software 6 03-12-2004 03:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration