-   Linux - Software (
-   -   sdl games are slow extremely slow (

linksocc 01-13-2004 12:09 AM

sdl games are slow extremely slow
Here is the problem, I'm trying to play a game called cube, at first I saw it was so slow I couldn't even move using a intel celeron 1.3 ghz cpu with 256 of ram in gentoo 1.4, then I tried another sdl game called neverball and it was the same, can somebody give me an advise in how to get sdl to work with hardware acceleration using nvida drivers for a geforce 2 card

megaspaz 01-13-2004 12:54 AM

did you install nvidia drivers (drivers from the nvidia's site)? i don't think the open source nvidia drivers have 3d acceleration built in. if you did, have you edited your XF86Config (or XF86Config-4) file to tell it to use the nvidia drivers?

i played cube the other night and was getting ~96 fps on my laptop nvidia geforce2 go card. the game actually gave me headache and made me nauseus.

linksocc 01-13-2004 01:13 AM

I'm using nvidia's drivers and I'm getting around 970.800 FPS in glxgears with 24 bit display and a resolution of 1152x864, (I can play quake 3 with all the settings to the max and a resolution of 1024x768 with no problems at all) so the problem is with SLD and the use of opengl

megaspaz 01-13-2004 01:35 AM

the only real thing i could suggest is trying a different version of sdl and/or opengl. don't really know of any configuration that you can really do with them.

JOPS 01-13-2004 01:48 AM

Some versions of the NVIDIA drivers may have some issues. Which version are you currently using?

linksocc 01-13-2004 04:44 PM

thanks for your answers but the problem was with compiling libsdl with alsa support, now that I compiled libsdl without alsa and using oss emulation games run with no problems at all:D

timcrafton 01-17-2004 03:39 PM

I am having the same issue with cube.. caould you please let me know what you did to fix the problem on yours... Thanx

linksocc 01-17-2004 03:53 PM

Well.. I'm using gentoo linux and I just did this

USE="-alsa oss" emerge libsdl
and that solved my problem but you have to be using gentoo linux for this to work maybe someone can post how to do it compiling it from from source

All times are GMT -5. The time now is 04:34 AM.