-   Linux - Software (
-   -   Scribus installation problem, sez I need automake 1.6 when automake 1.9 is istalled (

Rockgod2099 11-09-2004 04:16 PM

Scribus installation problem, sez I need automake 1.6 when automake 1.9 is istalled
I've been trying to install scribus 1.2, I have no problems with the configuration, but when I do make, I get a message that sez

[root@uac-182-86 scribus-1.2]# make
cd . && \
/bin/sh /home/rockgod/Guts/scribus-1.2/admin/missing --run automake-1.6 --foreign Makefile
/home/rockgod/Guts/scribus-1.2/admin/missing: line 46: automake-1.6: command not found
WARNING: `automake-1.6' is needed, and you do not seem to have it handy on your
system. You might have modified some files without having the
proper tools for further handling them. Check the `README' file,
it often tells you about the needed prerequirements for installing
this package. You may also peek at any GNU archive site, in case
some other package would contain this missing `automake-1.6' program.
make: *** [] Error 1

So I went and downloaded and installed the latest copy of automake (1.9) but I still get this message. Any ideas on why this is? I also tried using using yum to install scribus but I keep getting told that yum couldn't find scribus

[root@uac-182-86 scribus-1.2]# yum install scribus
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Cannot find a package matching scribus
No actions to take

Any help would be appreciated

kevinatkins 11-09-2004 06:11 PM


this migh be down to your environment variables.. Could you do a couple of quick tests for us and post back the output? ...

In a console, try :

'which automake' (omit quotes!)

- this should show where automake is installed...

then -

'automake --version'

- self-explanatory.


Rockgod2099 11-10-2004 01:45 PM

I did what you said and got this:

[rockgod@uac-182-86 rockgod]$ which automake
[rockgod@uac-182-86 rockgod]$ automake--version
bash: automake--version: command not found
[rockgod@uac-182-86 rockgod]$ automake-1.9
automake-1.9: `' or `' is required
[rockgod@uac-182-86 rockgod]$ automake --version
automake (GNU automake) 1.9
Written by Tom Tromey <>.

Copyright 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

Does this help? Any ideas on why Scribus won't install?

kevinatkins 11-10-2004 01:55 PM


is there an 'automake' symbolic link pointing to automake-1.9? and did you uninstall the original automake? this is kind of puzzling...

Rockgod2099 11-10-2004 09:21 PM

I don't remember ever uninstalling any version of auto-make, I don't know how I would do that, how would I tell if there is a symbolic link pointing to automake 1.9? Should I have a link or get rid of one if there is?

kevinatkins 11-11-2004 03:56 AM


Regarding symbolic links, etc..

Have a look in /usr/bin and check if there's any automake link in there - if there is, where is it pointing.. Hopefully to your new version, if not, make a note of where it points and rename it something like automake.old.

next, have a go at creating a symbolic link in pointing to your new automake version, eg, as root type -


ln -s /usr/local/bin/automake-1.9 /usr/bin/automake
Other than that, I'm a bit stuck!

dezza 11-11-2004 07:07 AM

Hey you should check this out! It explains it all! :) Scribus is one of the best tools for Linux i love it!

Good luck :D ..

Rockgod2099 11-11-2004 01:04 PM

I made a symbolic link, and still get the same "need auto-make 1.6" error. I then went to the links that dezza suggested. It still tells me that I have auto-make 1.9 when I type automake --version. I then tried

export WANT_AUTOMAKE="1.9" and the make still won't work.

I then tried the

export WANT_AUTOMAKE="1.6"

make still told me I needed automake 1.6

should I just install an older version of auto-make? roll back from 1.9 to 1.6?

Rockgod2099 11-11-2004 01:07 PM

Oh and this appears at the end of the configuration script. do you think this means anything?

Configuration Summary:

FreeType2 installed: Yes
CUPS installed: No
LittleCMS installed: No
TiffLib installed: No
The Scripter-Plugin will not be compiled.

Start make now.

kevinatkins 11-11-2004 02:45 PM


OK, must admit to being a little puzzled here...

The lines at the end of your config script summary are alright (although if you've got CUPS on your system, it might be worth installing the CUPS development libraries so that CUPS support gets compiled in... but that's an aside for now)

Anyway, I decided to have a go at compiling Scribus 1.2 on my system, to see if I could reproduce any of the issues you've got. Well, it's compiled fine, and I've got automake 1.4 on this box! So the version business is a bit of a red herring I think.

What I'm starting to wonder is whether your development environment is either incomplete or broken in some other way. When you installed the latest automake version, did you compile it from source or use an RPM (its location in /usr/local/bin suggests to me that you compiled it?)

Rockgod2099 11-11-2004 03:17 PM

yea I downloaded a tar of automake and uncompressed it. no rpms.

I used to have a problem doing the configuration with scribus because I didn't have C++ but I got it using yum and now I start running into problems when I type make

kevinatkins 11-11-2004 05:23 PM


This is getting intriguing and I've got to admit I'm not in the best position to advise further! I'm hoping some other people might be able to help out here, but for what it's worth...

Have you got autoconf on your system? I think that automake requires it, but I'd imagine you'd have run into that dependency when you compiled automake anyway..

there may be other issues or requirements about which I'm not aware, too. One other suggestion - if you've got a fedora cd set, you'll probably find all of the development tools on there and it might be easier to try that..

Good luck and I'm sorry I can't really be of further assistance!

Rockgod2099 11-11-2004 11:22 PM

well thanks for you help thus far, hopefully I'll be able to figure something out....

Rockgod2099 11-14-2004 06:37 PM


Put that at the end of your /etc/yum.conf file and (as root) type:
yum install scribus

I had to run yum install scribus twice in order to get it working but it did.

All times are GMT -5. The time now is 02:51 PM.