LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-17-2017, 12:09 AM   #1
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 26; HP Pavilion 8Gb and Acer Aspire 16Gb; both Intel Core-i7
Posts: 266

Rep: Reputation: 22
Scribus 1.4.6 spell checker?


I'm sure I have used a spell checker in Scribus 1.4.6 before, triggered by F7, but now I can't get it working. The only reference I can find in Scribus is under File/Preferences/Hyphenation and Spelling/Spelling, but that only lists the spelling dictionaries.

I Googled and found this post, but there is no 'Check Spelling" option anywhere.

Anybody able to enlighten me as to what I am doing wrong? Do I need to install something? "8-[

Cheers,
Doug
 
Old 01-17-2017, 02:17 AM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
Doug,

There is in fact a Check Spelling option in Scribus 1.4.6.

Right click on the selected text and then click on Edit Text.

At the top there is another Edit tab.

Click on this Edit and you will see the Check Spelling option.

I have not set my Styles, as per the link you mentioned, so Check Spelling does not work on my deliberate spelling errors.

Once you set the various Styles correctly, the spell checker should hopefully work.

EDIT #1:

Hyphenation and Spellchecking:
https://www.scribus.net/svn/Scribus/...yphenator.html

For spellchecking Scribus uses the Hunspell library, which is also utilized by other popular programs like LibreOffice, Firefox or InDesign.

Configuration:

Under File > Preferences > Hyphenation and Spelling you find a second tab called “Spelling”.
The purpose of this dialog is not the configuration of spellchecking options per se, but the management of available dictionaries.

Extract:
Quote:
Now in your Scribus document, you need to align the style-language(s)
for that text with the actual language of the text, otherwise you will
have to set the spell checker for each word. Go

menu > edit > Styles...

and then (if your text is using default style, as an example) go:

Default Paragraph Style > Edit > Character Style tab > set the language
to whatever your text is (for example Russian)

If you know about styles, you can also clone a style and have one style
for each language that you work with.
EDIT #2:

My original dictionary was en_US. I then added en_GB and set all my Styles to Default Style.

I then right clicked to bring up Edit Text.

Then (top tab) clicked on Edit > Check Spelling.

All my errors were found. Spell checker works!!

Use Ignore Once/All or Change/All to correct the spelling.

Last edited by beachboy2; 01-17-2017 at 05:42 AM.
 
Old 01-17-2017, 11:56 PM   #3
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 26; HP Pavilion 8Gb and Acer Aspire 16Gb; both Intel Core-i7
Posts: 266

Original Poster
Rep: Reputation: 22
Thanks for your reply.
Quote:
Originally Posted by beachboy2 View Post
Right click on the selected text and then click on Edit Text.
At this point, I am in the Story Editor - right?
Quote:
Originally Posted by beachboy2 View Post
At the top there is another Edit tab.
Yep.
Quote:
Originally Posted by beachboy2 View Post
Click on this Edit and you will see the Check Spelling option.
Nope - that menu option is not present. Sigh.

When I edit Scribus Preferences/Hyphenation and Spelling/Spelling, I see it has somehow installed every imaginable version of English and I imagine this would confuse the spell checker, but I can't see how to uninstall everything except en_AU (Australian).
Quote:
Originally Posted by beachboy2 View Post
Once you set the various Styles correctly, the spell checker should hopefully work.
All my styles are based on Default Style, which uses English characters, so all my styles do too.
Quote:
Originally Posted by beachboy2 View Post
Under File > Preferences > Hyphenation and Spelling you find a second tab called “Spelling”.
The purpose of this dialog is not the configuration of spellchecking options per se, but the management of available dictionaries.
That would be great if I could 'manage' away en_<everything other than AU>.

I'll keep bashing my head against the keyboard until I see the light. "8-)
 
Old 01-18-2017, 12:52 AM   #4
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
Doug,

Quote:
That would be great if I could 'manage' away en_<everything other than AU>.
There is no need to do that.

My Spell Checker is working perfectly with en_US and en-GB installed in Scribus 1.4.6.

You are correct with the first two moves.

1. You are in Story Editor.
2. You click on the Edit tab at the top. Unfortunately I cannot show a screenshot of the various options ,including Check Spelling, whilst in the middle of selecting an option.

I can show other screenshots (attached).

Quote:
Nope - that menu option is not present. Sigh.
Very strange.

I cannot find out how to remove an installed dictionary.

All I can find is this, which has no explanation about dictionary removal:

Quote:
If you have dictionaries for more than one language installed, or more than one dictionary for a single language, the spellchecker may not work correctly or not at all. For example, if your character style uses “English” as the language setting, using the dictionary “en_US” (US-American English) won’t work, as “English” is being mapped to “en_GB”. Likewise, “German” will be mapped to “de_DE”. This cannot be fixed in the 1.4.x series because it would break backward compatibility with Scribus files created with prior 1.4.x versions. The file format of the next Scribus version will handle this correctly.
As a workaround you can either install the working version (e.g. en_GB or de_DE) or to remove or temporarily disable (=rename) other dictionaries.


You could try uninstalling scribus 1.4.6 and reinstalling it, either via command line or Synaptic.
You should then only have a single dictionary (en_US) installed by default.

Then you can either add the en_AU dictionary or just leave things alone.

If this makes no difference, then I suggest that you contact Martin Zaske.

His email address is at the top of this link:
http://lists.scribus.net/pipermail/s...il/053176.html

EDIT:
I have also attached screenshots for Style Manager and Default Character Style.
(some are on the next post)
Attached Thumbnails
Click image for larger version

Name:	Story Editor-1.png
Views:	49
Size:	250.2 KB
ID:	24000   Click image for larger version

Name:	Spell Checker-1.png
Views:	50
Size:	193.2 KB
ID:	24001   Click image for larger version

Name:	Spell Checker-2.png
Views:	25
Size:	201.7 KB
ID:	24002   Click image for larger version

Name:	Spell Checker-3.png
Views:	22
Size:	205.4 KB
ID:	24003   Click image for larger version

Name:	Style Manager-1.png
Views:	29
Size:	243.9 KB
ID:	24004  


Last edited by beachboy2; 01-18-2017 at 01:21 AM.
 
Old 01-18-2017, 01:09 AM   #5
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
Doug,

Max of 5 screenshots on earlier post.

2 more attached here.

Try uninstalling Scribus and then reinstalling it (version 1.4.6).

Just use the default en_US dictionary/language for now.

I have a feeling that your problem is related to the setting of Styles somewhere or other within Scribus.
Attached Thumbnails
Click image for larger version

Name:	Style Manager-2.png
Views:	26
Size:	244.6 KB
ID:	24005   Click image for larger version

Name:	Default Character Style.jpg
Views:	26
Size:	169.2 KB
ID:	24006  

Last edited by beachboy2; 01-18-2017 at 01:17 AM.
 
Old 01-19-2017, 12:37 AM   #6
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 26; HP Pavilion 8Gb and Acer Aspire 16Gb; both Intel Core-i7
Posts: 266

Original Poster
Rep: Reputation: 22
Thanks very much for all the trouble you are going to.
Quote:
Originally Posted by beachboy2 View Post
Try uninstalling Scribus and then reinstalling it (version 1.4.6).
Uninstalled Scribus, renamed my .scribus directory, did a fresh install of Scribus, deleted from /usr/share/myspell all except en_AU and en_GB. Opened Scribus, created a one-page document, added a text box, filled it with sample text, set it all to Default Paragraph Style and Default Character Style, chose Edit/Edit Text to bring up the Story Editor, opened the Edit menu and there is still no 'Check Spelling" option - see attached screenshot.
Quote:
Originally Posted by beachboy2 View Post
I have a feeling that your problem is related to the setting of Styles somewhere or other within Scribus.
In this fresh installation and fresh .scribus, there are only the two styles: Default Paragraph and Default Character, which are both set to English.

There must be something about my setup that is suppressing the "Check Spelling" menu option from even appearing as an inactive option, but what?

I think I will take your advice and contact Martin Zaske.
Attached Thumbnails
Click image for larger version

Name:	Story Editor Edit Menu.png
Views:	21
Size:	33.2 KB
ID:	24012  
 
Old 01-19-2017, 01:09 AM   #7
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Hi Doug....

As beachboy2 mentioned in post #2 under "Edit #1," out of curiosity, what do you see listed under "File-->Preferences-->Hyphenation and Spelling" since you reinstalled the software? I have a copy of 1.4.2 installed and see Hunspell listed under mine...
Attached Thumbnails
Click image for larger version

Name:	Scribus screenshot.jpg
Views:	28
Size:	184.1 KB
ID:	24013  

Last edited by ardvark71; 01-19-2017 at 01:13 AM. Reason: Added wordage.
 
Old 01-19-2017, 02:15 AM   #8
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
Doug,

See if you can solve it yourself first.

In post #4 look at the first screenshot Story Editor Text1.png.

At the middle top you should see Default Paragraph Style, NOT None.

On the left hand side, ALL the settings should be set to Default Paragraph Style.

I suspect that at least one of your settings is incorrect.

If that doesn't work, I suggest that you have one last try and use Synaptic to totally remove Scribus and all its dependencies.

Make sure that these folders and their contents no longer exist:

Code:
/usr/share/hunspell
and

Code:
/home/doug/.scribus
When you reinstall Scribus 1.4.6, en_US will be the default. Do NOT add anything!

Set all the Styles correctly, close Scribus and then reopen it.

If that does not work then contact Martin Zaske.

If it works, then I would advise just adding en_GB because Commonwealth expressions are supposed to be covered by this dictionary anyway.

My Spell Checker in Scribus 1.4.6 works perfectly using en_US and en_GB, as you can see from the various screenshots.

Somewhere, one or more of your settings is incorrect.

You will solve this shortly.

Good luck.

Last edited by beachboy2; 01-19-2017 at 02:19 AM.
 
Old 01-19-2017, 05:35 AM   #9
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
ardvark71,

Is your spell checker working?
 
Old 01-19-2017, 12:30 PM   #10
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by beachboy2 View Post
Is your spell checker working?
Hi...

I'm afraid it's not. I've been working through the information I found here, however, I can't find the "Resource Manager" for 1.4.2, if there is one. Be sure to download and watch the video offered in the 5th post to gain a better understanding of what I mean.

I've looked through your posts but apart from reinstalling and deleting files (which I don't really want to do,) I'm not seeing anything that stands out in my case.

EDIT: I just tested a Windows version of 1.4.2 on my copy of Vista and the spell checker works great.

Regards...

Last edited by ardvark71; 01-19-2017 at 01:12 PM. Reason: Correction/Added emoticon and comments.
 
Old 01-19-2017, 01:10 PM   #11
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
ardvark71,

Just looked at the video.

It does not tally with my experience or my screenshots above.

The spell checker works perfectly in Scribus 1.4.6 using en_US and en_GB.

I would still recommend complete removal of Scribus 1.4.2 and then installing version 1.4.6:

Code:
sudo apt-get install scribus
Then try again as I recommended to Doug.

Somewhere the settings are incorrect in both of your cases.
 
Old 01-19-2017, 01:16 PM   #12
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by beachboy2 View Post
I would still recommend complete removal of Scribus 1.4.2 and then installing version 1.4.6
Hi...

Thanks! 1.4.6 isn't available for Lubuntu 14.04, I already checked in Synaptic. I could check Ubuntu's repositories to see if there are any changes in the dependencies...

Regards...
 
Old 01-19-2017, 01:20 PM   #13
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
ardvark71,

I assumed that you were using Lubuntu 16.04.

I know, never assume!

I guess you have already seen this:
http://ubuntuhandbook.org/index.php/...table-release/
 
Old 01-19-2017, 01:58 PM   #14
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by beachboy2 View Post
ardvark71,

I assumed that you were using Lubuntu 16.04.

I know, never assume!
No worries, I appreciate the help!

But...I figured out my problem and got it fixed, praise God, and it might work for the OP, too!

Location of the dictionary file is key here. Take a look at my screenshot below and compare it with the one above. All I did was download a new US dictionary, as offered on the right hand side. Installing the one from the UK clued me in as to the location difference. In my case, Scribus immediately set the default to the new dictionary in the new location. And I didn't have to uninstall Hunspell.

Doug, let us know if you need more help but what I wrote above worked for me.

Thanks again, beachboy2!

Regards...
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2017-01-19 11:51:20.jpg
Views:	56
Size:	208.6 KB
ID:	24016  

Last edited by ardvark71; 01-19-2017 at 02:02 PM. Reason: Forgot to add screenshot...heh. ;-)
 
Old 01-19-2017, 02:02 PM   #15
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
ardvark71,

I did exactly the same thing (see attached screenshot)!
Attached Thumbnails
Click image for larger version

Name:	Spelling Dictionaries.png
Views:	49
Size:	180.4 KB
ID:	24017  

Last edited by beachboy2; 01-19-2017 at 02:06 PM.
 
  


Reply

Tags
scribus, spell checker


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spell Checker Kahless LQ Suggestions & Feedback 4 07-15-2007 11:35 PM
Spell Checker royleith Linux - Desktop 2 06-15-2007 07:30 AM
The spell checker Indiestory LQ Suggestions & Feedback 4 02-28-2007 04:55 PM
I need a spell checker halfpower Debian 3 05-22-2006 11:45 AM
Your Spell-Checker Robert G. Hays LQ Suggestions & Feedback 4 03-23-2005 01:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration