LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Scribus 1.4.6 spell checker? (https://www.linuxquestions.org/questions/linux-software-2/scribus-1-4-6-spell-checker-4175597620/)

Doug Hutcheson 01-17-2017 01:09 AM

Scribus 1.4.6 spell checker?
 
I'm sure I have used a spell checker in Scribus 1.4.6 before, triggered by F7, but now I can't get it working. The only reference I can find in Scribus is under File/Preferences/Hyphenation and Spelling/Spelling, but that only lists the spelling dictionaries.

I Googled and found this post, but there is no 'Check Spelling" option anywhere.

Anybody able to enlighten me as to what I am doing wrong? Do I need to install something? "8-[

Cheers,
Doug

beachboy2 01-17-2017 03:17 AM

Doug,

There is in fact a Check Spelling option in Scribus 1.4.6.

Right click on the selected text and then click on Edit Text.

At the top there is another Edit tab.

Click on this Edit and you will see the Check Spelling option.

I have not set my Styles, as per the link you mentioned, so Check Spelling does not work on my deliberate spelling errors.

Once you set the various Styles correctly, the spell checker should hopefully work.

EDIT #1:

Hyphenation and Spellchecking:
https://www.scribus.net/svn/Scribus/...yphenator.html

For spellchecking Scribus uses the Hunspell library, which is also utilized by other popular programs like LibreOffice, Firefox or InDesign.

Configuration:

Under File > Preferences > Hyphenation and Spelling you find a second tab called “Spelling”.
The purpose of this dialog is not the configuration of spellchecking options per se, but the management of available dictionaries.

Extract:
Quote:

Now in your Scribus document, you need to align the style-language(s)
for that text with the actual language of the text, otherwise you will
have to set the spell checker for each word. Go

menu > edit > Styles...

and then (if your text is using default style, as an example) go:

Default Paragraph Style > Edit > Character Style tab > set the language
to whatever your text is (for example Russian)

If you know about styles, you can also clone a style and have one style
for each language that you work with.
EDIT #2:

My original dictionary was en_US. I then added en_GB and set all my Styles to Default Style.

I then right clicked to bring up Edit Text.

Then (top tab) clicked on Edit > Check Spelling.

All my errors were found. Spell checker works!!

Use Ignore Once/All or Change/All to correct the spelling.

Doug Hutcheson 01-18-2017 12:56 AM

Thanks for your reply.
Quote:

Originally Posted by beachboy2 (Post 5656049)
Right click on the selected text and then click on Edit Text.

At this point, I am in the Story Editor - right?
Quote:

Originally Posted by beachboy2 (Post 5656049)
At the top there is another Edit tab.

Yep.
Quote:

Originally Posted by beachboy2 (Post 5656049)
Click on this Edit and you will see the Check Spelling option.

Nope - that menu option is not present. Sigh.

When I edit Scribus Preferences/Hyphenation and Spelling/Spelling, I see it has somehow installed every imaginable version of English and I imagine this would confuse the spell checker, but I can't see how to uninstall everything except en_AU (Australian).
Quote:

Originally Posted by beachboy2 (Post 5656049)
Once you set the various Styles correctly, the spell checker should hopefully work.

All my styles are based on Default Style, which uses English characters, so all my styles do too.
Quote:

Originally Posted by beachboy2 (Post 5656049)
Under File > Preferences > Hyphenation and Spelling you find a second tab called “Spelling”.
The purpose of this dialog is not the configuration of spellchecking options per se, but the management of available dictionaries.

That would be great if I could 'manage' away en_<everything other than AU>.

I'll keep bashing my head against the keyboard until I see the light. "8-)

beachboy2 01-18-2017 01:52 AM

5 Attachment(s)
Doug,

Quote:

That would be great if I could 'manage' away en_<everything other than AU>.
There is no need to do that.

My Spell Checker is working perfectly with en_US and en-GB installed in Scribus 1.4.6.

You are correct with the first two moves.

1. You are in Story Editor.
2. You click on the Edit tab at the top. Unfortunately I cannot show a screenshot of the various options ,including Check Spelling, whilst in the middle of selecting an option.

I can show other screenshots (attached).

Quote:

Nope - that menu option is not present. Sigh.
Very strange.

I cannot find out how to remove an installed dictionary.

All I can find is this, which has no explanation about dictionary removal:

Quote:

If you have dictionaries for more than one language installed, or more than one dictionary for a single language, the spellchecker may not work correctly or not at all. For example, if your character style uses “English” as the language setting, using the dictionary “en_US” (US-American English) won’t work, as “English” is being mapped to “en_GB”. Likewise, “German” will be mapped to “de_DE”. This cannot be fixed in the 1.4.x series because it would break backward compatibility with Scribus files created with prior 1.4.x versions. The file format of the next Scribus version will handle this correctly.
As a workaround you can either install the working version (e.g. en_GB or de_DE) or to remove or temporarily disable (=rename) other dictionaries.


You could try uninstalling scribus 1.4.6 and reinstalling it, either via command line or Synaptic.
You should then only have a single dictionary (en_US) installed by default.

Then you can either add the en_AU dictionary or just leave things alone.

If this makes no difference, then I suggest that you contact Martin Zaske.

His email address is at the top of this link:
http://lists.scribus.net/pipermail/s...il/053176.html

EDIT:
I have also attached screenshots for Style Manager and Default Character Style.
(some are on the next post)

beachboy2 01-18-2017 02:09 AM

2 Attachment(s)
Doug,

Max of 5 screenshots on earlier post.

2 more attached here.

Try uninstalling Scribus and then reinstalling it (version 1.4.6).

Just use the default en_US dictionary/language for now.

I have a feeling that your problem is related to the setting of Styles somewhere or other within Scribus.

Doug Hutcheson 01-19-2017 01:37 AM

1 Attachment(s)
Thanks very much for all the trouble you are going to.
Quote:

Originally Posted by beachboy2 (Post 5656572)
Try uninstalling Scribus and then reinstalling it (version 1.4.6).

Uninstalled Scribus, renamed my .scribus directory, did a fresh install of Scribus, deleted from /usr/share/myspell all except en_AU and en_GB. Opened Scribus, created a one-page document, added a text box, filled it with sample text, set it all to Default Paragraph Style and Default Character Style, chose Edit/Edit Text to bring up the Story Editor, opened the Edit menu and there is still no 'Check Spelling" option - see attached screenshot.
Quote:

Originally Posted by beachboy2 (Post 5656572)
I have a feeling that your problem is related to the setting of Styles somewhere or other within Scribus.

In this fresh installation and fresh .scribus, there are only the two styles: Default Paragraph and Default Character, which are both set to English.

There must be something about my setup that is suppressing the "Check Spelling" menu option from even appearing as an inactive option, but what?

I think I will take your advice and contact Martin Zaske.

ardvark71 01-19-2017 02:09 AM

1 Attachment(s)
Hi Doug....

As beachboy2 mentioned in post #2 under "Edit #1," out of curiosity, what do you see listed under "File-->Preferences-->Hyphenation and Spelling" since you reinstalled the software? I have a copy of 1.4.2 installed and see Hunspell listed under mine...

beachboy2 01-19-2017 03:15 AM

Doug,

See if you can solve it yourself first.

In post #4 look at the first screenshot Story Editor Text1.png.

At the middle top you should see Default Paragraph Style, NOT None.

On the left hand side, ALL the settings should be set to Default Paragraph Style.

I suspect that at least one of your settings is incorrect.

If that doesn't work, I suggest that you have one last try and use Synaptic to totally remove Scribus and all its dependencies.

Make sure that these folders and their contents no longer exist:

Code:

/usr/share/hunspell
and

Code:

/home/doug/.scribus
When you reinstall Scribus 1.4.6, en_US will be the default. Do NOT add anything!

Set all the Styles correctly, close Scribus and then reopen it.

If that does not work then contact Martin Zaske.

If it works, then I would advise just adding en_GB because Commonwealth expressions are supposed to be covered by this dictionary anyway.

My Spell Checker in Scribus 1.4.6 works perfectly using en_US and en_GB, as you can see from the various screenshots.

Somewhere, one or more of your settings is incorrect.

You will solve this shortly.

Good luck.

beachboy2 01-19-2017 06:35 AM

ardvark71,

Is your spell checker working?

ardvark71 01-19-2017 01:30 PM

Quote:

Originally Posted by beachboy2 (Post 5657262)
Is your spell checker working?

Hi...

I'm afraid it's not. I've been working through the information I found here, however, I can't find the "Resource Manager" for 1.4.2, if there is one. Be sure to download and watch the video offered in the 5th post to gain a better understanding of what I mean. :(

I've looked through your posts but apart from reinstalling and deleting files (which I don't really want to do,) I'm not seeing anything that stands out in my case.

EDIT: I just tested a Windows version of 1.4.2 on my copy of Vista and the spell checker works great. :scratch:

Regards...

beachboy2 01-19-2017 02:10 PM

ardvark71,

Just looked at the video.

It does not tally with my experience or my screenshots above.

The spell checker works perfectly in Scribus 1.4.6 using en_US and en_GB.

I would still recommend complete removal of Scribus 1.4.2 and then installing version 1.4.6:

Code:

sudo apt-get install scribus
Then try again as I recommended to Doug.

Somewhere the settings are incorrect in both of your cases.

ardvark71 01-19-2017 02:16 PM

Quote:

Originally Posted by beachboy2 (Post 5657420)
I would still recommend complete removal of Scribus 1.4.2 and then installing version 1.4.6

Hi...

Thanks! 1.4.6 isn't available for Lubuntu 14.04, I already checked in Synaptic. I could check Ubuntu's repositories to see if there are any changes in the dependencies...

Regards...

beachboy2 01-19-2017 02:20 PM

ardvark71,

I assumed that you were using Lubuntu 16.04.

I know, never assume!

I guess you have already seen this:
http://ubuntuhandbook.org/index.php/...table-release/

ardvark71 01-19-2017 02:58 PM

1 Attachment(s)
Quote:

Originally Posted by beachboy2 (Post 5657427)
ardvark71,

I assumed that you were using Lubuntu 16.04.

I know, never assume!

No worries, I appreciate the help! :)

But...I figured out my problem and got it fixed, praise God, and it might work for the OP, too! :) :thumbsup:

Location of the dictionary file is key here. Take a look at my screenshot below and compare it with the one above. All I did was download a new US dictionary, as offered on the right hand side. Installing the one from the UK clued me in as to the location difference. In my case, Scribus immediately set the default to the new dictionary in the new location. And I didn't have to uninstall Hunspell. :)

Doug, let us know if you need more help but what I wrote above worked for me.

Thanks again, beachboy2! :)

Regards...

beachboy2 01-19-2017 03:02 PM

1 Attachment(s)
ardvark71,

I did exactly the same thing (see attached screenshot)!

ardvark71 01-19-2017 03:08 PM

Quote:

Originally Posted by beachboy2 (Post 5657454)
I did exactly the same thing!

I didn't notice that in the screenshot but perhaps I skimmed too quickly through your instructions to see that! My apologies if that's the case. :)

Lord willing, I though I might download a copy of MX-16 today and give a live session a whirl. :)

Regards...

ardvark71 01-19-2017 03:13 PM

Quote:

Originally Posted by beachboy2 (Post 5657454)
I did exactly the same thing (see attached screenshot)!

Oh, that's right! But at the time, I didn't catch at all what you meant by that. :D

Regards...

Doug Hutcheson 01-19-2017 10:20 PM

Quote:

Originally Posted by ardvark71 (Post 5657197)
I have a copy of 1.4.2 installed and see Hunspell listed under mine...

Hi Aardvark.

I have 1.4.6 and see my dictionaries in /usr/share/myspell.

ardvark71 01-19-2017 10:29 PM

Quote:

Originally Posted by Doug Hutcheson (Post 5657640)
Hi Aardvark.

Hello :)

Quote:

Originally Posted by Doug Hutcheson (Post 5657640)
I have 1.4.6 and see my dictionaries in /usr/share/myspell.

Please take a look at post #14, that should solve your problem. :)

Regards...

Doug Hutcheson 01-19-2017 11:01 PM

1 Attachment(s)
Quote:

Originally Posted by beachboy2 (Post 5657454)
ardvark71,

I did exactly the same thing (see attached screenshot)!

Thank you both for hanging in with me.

My dictionaries were pointing to /usr/share/myspell.

I deleted /usr/share/myspell and ~/.scribus.

I am on Fedora, so I used dnf to delete Scribus then reinstall it.

Opened Scribus and looked at Hyphenation/Spelling and found no dictionaries at all. Selected en_US from the downloadable list and it went into .scribus/dicts.

Created a new document and added a text frame filled with sample text. Checked my Default styles and ensured they were both using English.

So far, so good.

Now I chose Edit/Edit Text to bring up the Story Editor and hopefully clicked the Edit menu. As you can see from the attached image, there is no Check Spelling option.

Groan!

I can't imagine how I could have started with a cleaner system short of formatting my disk. Where to now?

"8-[

beachboy2 01-20-2017 12:06 AM

Doug,

All I can think of is that it is possibly related to Fedora.

There are no problems with Spell Checker in Linux MInt 18 MATE.

I have these locations:

Code:

/usr/share/hunspell/en_US
and

Code:

/home/myusername/.scribus/dicts/en_GB
If you have a spare computer, install Linux Mint MATE 18.1.


Alternatively install VirtualBox on your existing computer and install LM inside that.

EDIT:

Quote:

Opened Scribus and looked at Hyphenation/Spelling and found no dictionaries at all.
There is definitely something wrong here.

Immediately after installing Scribus 1.4.6 you should have this default location:

Code:

/usr/share/hunspell/en_US

ardvark71 01-20-2017 12:42 AM

Quote:

Originally Posted by Doug Hutcheson (Post 5657652)
Where to now?

Hi...

Also, while using Story Editor, does pressing the "Shift + F7" keys bring anything up? :scratch:

Regards...

Doug Hutcheson 01-20-2017 12:43 AM

Yes, I will try a virtual machine. Other than that, I give up! "8-[

Thanks for all the assistance anyway.

beachboy2 01-20-2017 12:45 AM

Doug,

Hopefully VirtualBox and LM 18 MATE will help solve your problem.

In addition, you can always email Martin Zaske.

ardvark71 01-20-2017 12:46 AM

Quote:

Originally Posted by Doug Hutcheson (Post 5657671)
Yes, I will try a virtual machine. Other than that, I give up! "8-[

Thanks for all the assistance anyway.

Take a look at my post above, you may not have noticed it. ;)

Regards...

Doug Hutcheson 01-21-2017 01:59 AM

Quote:

Originally Posted by ardvark71 (Post 5657670)
Also, while using Story Editor, does pressing the "Shift + F7" keys bring anything up? :scratch:

Sadly, no. "8-[

ardvark71 01-21-2017 02:06 AM

Quote:

Originally Posted by Doug Hutcheson (Post 5658085)
Sadly, no. "8-[

Hi...

Hmm, in that case, let us know how it works using a VM and/or what Martin Zaske has to say. :(

Regards...

Doug Hutcheson 01-21-2017 04:56 AM

Quote:

Originally Posted by beachboy2 (Post 5657673)
Hopefully VirtualBox and LM 18 MATE will help solve your problem.

In addition, you can always email Martin Zaske.

I don't think I need to trouble Martin just yet. I downloaded a fresh Fedora 25 .iso and installed it in a virtual machine. I then installed Scribus. So far, a pristine installation. I then checked the spelling and style settings. I created a new document with a text frame containing standard text. I opened the story editor and selected the Edit menu. Surprise surprise, there was no Check Spelling option!

It looks as though the version in the Fedora repository has no spell checker installed, for reasons I cannot imagine.

I am now taking this problem to the Fedora forum. Hopefully someone there will be able to explain what is going on.

I am extremely grateful to you both for your advice and suggestions. The Linux community is a good place to be.

Kind regards,
Doug

beachboy2 01-21-2017 06:52 AM

Doug,

I thought that the whole point of installing VirtualBox was for you to then install Linux Mint 18.1 MATE, which has a functioning spell checker, not Fedora 25?

Fedora appears to be the cause of the missing spell checker.

Quote:

The Linux community is a good place to be.
Indeed it is.

ardvark71 01-21-2017 02:44 PM

Quote:

Originally Posted by Doug Hutcheson (Post 5658115)
I don't think I need to trouble Martin just yet. I downloaded a fresh Fedora 25 .iso and installed it in a virtual machine. I then installed Scribus. So far, a pristine installation. I then checked the spelling and style settings. I created a new document with a text frame containing standard text. I opened the story editor and selected the Edit menu. Surprise surprise, there was no Check Spelling option!

It looks as though the version in the Fedora repository has no spell checker installed, for reasons I cannot imagine.

Your issue is a strange one as I would think software packages like Scribus would be uniform across the distributions, although I could be wrong. :scratch:

Quote:

Originally Posted by Doug Hutcheson (Post 5658115)
I am now taking this problem to the Fedora forum. Hopefully someone there will be able to explain what is going on.

Please let us know what you find out. I'd be curious to know what the issue is and what solution, if any, is successful at resolving it.

Quote:

Originally Posted by Doug Hutcheson (Post 5658115)
I am extremely grateful to you both for your advice and suggestions.

You're welcome, I hope you are able to get it resolved. :)

Regards...

Doug Hutcheson 01-22-2017 02:49 AM

Quote:

Originally Posted by beachboy2 (Post 5658157)
I thought that the whole point of installing VirtualBox was for you to then install Linux Mint 18.1 MATE, which has a functioning spell checker

I forgot to explain I had downloaded to MATE .iso and tried to install it into a VM, but could not make it work. I will try again with more coffee. "8-)

Doug Hutcheson 01-22-2017 03:40 AM

Quote:

Originally Posted by beachboy2 (Post 5658157)
I thought that the whole point of installing VirtualBox was for you to then install Linux Mint 18.1 MATE, which has a functioning spell checker, not Fedora 25?

Yes, I should have mentioned I did try installing MATE but had trouble with the VM manager.

I installed Fedora to prove it would not work with a pristine installation.

I have now successfully installed and run MATE using a different VM manager and it is just as we expected: only the USA dictionary was installed and spell checking works perfectly from the Item menu, from the Story Editor and using Shift+F7.

SO, is it the use of en_GB and en_AU dictionaries that is confusing Scribus on Fedora, or is there a switch I am not switching? I will pursue this on the Fedora forum. If no luck there I will contact Martin. I don't want to bother him until I have all the evidence sewn up. "8-)

Cheers,
Doug

beachboy2 01-22-2017 05:13 AM

Doug,

Quote:

I have now successfully installed and run MATE using a different VM manager and it is just as we expected: only the USA dictionary was installed and spell checking works perfectly from the Item menu, from the Story Editor and using Shift+F7.

SO, is it the use of en_GB and en_AU dictionaries that is confusing Scribus on Fedora
Why don't you add the en_GB and en_AU dictionaries to Scribus in Linux Mint MATE and then see if the spell checker still works.

I am confident that it will do so.

I suspect that Fedora has something (or is missing something) which prevents the spell checker operating correctly in Scribus.

Doug Hutcheson 01-23-2017 01:38 AM

Quote:

Originally Posted by beachboy2 (Post 5658518)
Why don't you add the en_GB and en_AU dictionaries to Scribus in Linux Mint MATE and then see if the spell checker still works.

I should have done that before - thanks for picking me up on it. I downloaded all the 5 English dialects available to MATE and found the spell checker was still working.

Quote:

Originally Posted by beachboy2 (Post 5658518)
I suspect that Fedora has something (or is missing something) which prevents the spell checker operating correctly in Scribus.

Yes, I agree.

Scribus on Fedora has 24 English dictionaries for every country imaginable, but all but a couple are sym links to en_GB. I can imagine the spell checker getting confused of this many dictionaries, but cannot see how to remove them from within Scribus.

I have had no response form the Fedora Forum yet, so it is not high on anyone's radar I suppose.

I checked the Help/About information. Fedora and MATE are using the same build, but MATE is using Ghostscript 9.18 whereas Fedora is using 9.20. This difference can have nothing to do with my problem

I'll keep seeking an answer and will post here if I find it.

In the meantime, I see there is a 1.52 development release available, so I'll try to set that up in my Fedora VM and see what happens.

Cheers,
Doug

beachboy2 01-23-2017 02:07 AM

Doug,

Quote:

I have had no response form the Fedora Forum yet, so it is not high on anyone's radar I suppose.
I don't think that Scribus is particularly high on anybody's radar, not just the Fedora Forum's.

This is a pity because Scribus is a powerful Desktop Publishing application which is open-source and free. Not too many people appear to be aware of its existence.

Of course professional users will pay monthly subscriptions for Adobe's InDesign DTP software.

For the amateur/semi-pro user then Scribus fits the bill quite nicely.

A local group in my area currently uses the outdated Adobe PageMaker to produce a monthly newsletter on a member's old Windows PC.
Since this software will not run on recent versions of Windows, it is necessary to find an alternative DTP application and Scribus is the main replacement candidate.

I don't know whether Martin Zaske is fully clued up on Fedora, but he would seem to be the best person to contact regarding the technical requirements of Scribus running on a Linux platform.

Doug Hutcheson 01-23-2017 04:15 AM

A clue:

In document https://wiki.scribus.net/canvas/Building_SVN_versions_with_CMake

Is the information:
Code:

Version 1.5.x

Here is a list of dependencies for Scribus 1.5.x:

...
Libhunspell (if missing, spellchecker won't work)
...

On my system I have:
Code:

[root@KETCHUP doug]# ls -l /usr/lib64/libhunspell*
lrwxrwxrwx. 1 root root    24 May  3  2016 /usr/lib64/libhunspell-1.4.so.0 -> libhunspell-1.4.so.0.0.0
-rwxr-xr-x. 1 root root 517080 May  3  2016 /usr/lib64/libhunspell-1.4.so.0.0.0

So I don't exactly have libhunspell, I have libhunspell-1.4.so.0 - could this be a problem? More investigation needed ...

beachboy2 01-23-2017 04:33 AM

Doug,

The above link does not work.

Hopefully this one will:
https://wiki.scribus.net/canvas/Buil...ecking_out_SVN

My libhunspell is even older, libhunspell-1.3-0 with installed version 1.3.3-4ubuntu1.

You need to follow the advice in that link and try one of their suggested routes.

beachboy2 01-23-2017 11:00 AM

Doug,

Just for the hell of it, why not try Chapeau 24, which is based on Fedora 24 but has a few more tweaks?

http://chapeaulinux.org/chapeau-24-is-out-now/

Doug Hutcheson 01-24-2017 12:27 AM

Quote:

Originally Posted by beachboy2 (Post 5658869)
I don't think that Scribus is particularly high on anybody's radar, not just the Fedora Forum's.

Yes, it is a shame it is not well known. I write a monthly newsletter in Scribus and have no need for anything more powerful.
Quote:

Originally Posted by beachboy2 (Post 5658869)
I don't know whether Martin Zaske is fully clued up on Fedora, but he would seem to be the best person to contact regarding the technical requirements of Scribus running on a Linux platform.

I have joined the Scribus forum and posted my question there. I'll let you know if I find anything.

As I write, my system is compiling the Scribus 1.5.2 source and it will be interesting to see if I have spell checking when it finishes. The compiler certainly picked up Hunspell, so the chances are it will work.

Doug Hutcheson 01-24-2017 12:28 AM

Quote:

Originally Posted by beachboy2 (Post 5659057)
Just for the hell of it, why not try Chapeau 24, which is based on Fedora 24 but has a few more tweaks?

http://chapeaulinux.org/chapeau-24-is-out-now/

I will set up a VM for it and have a look. Thanks for the suggestion.

Doug Hutcheson 01-24-2017 12:57 AM

You may be interested to know the testing-only version 1.5.3 compiled on my system and has the spell checker. It is under the 'Extras' menu now and is still able to be invokes with Shift+F7.

So what is wrong with my 1.4.6 version? (Cue the sounds of gnashing teeth and banging head.)

beachboy2 01-24-2017 01:59 AM

Doug,

I am afraid that I don't have an answer.

I know you are using Scribus 1.5.3 testing but all I can find is this:

Quote:

The Scribus Team is very pleased to announce the release of the development version Scribus 1.5.2, which is another major step onto the next fully-featured version 1.6.0. In terms of stability, 1.5.2 can be already be regarded as robust. The Scribus Team encourages the wide-spread use and testing of version 1.5.2 in as many environments as possible. User feedback will help us to release a rock-solid version 1.6.0.
https://wiki.scribus.net/canvas/1.5.2_Release

Get in touch with Scribus and point them to this thread.

Also ask them when Scribus 1.6.0 is due to be released.

Failing that, maybe Uri Geller can help you:
http://www.dailymail.co.uk/news/arti...ic-powers.html

ardvark71 01-24-2017 03:11 AM

Quote:

Originally Posted by Doug Hutcheson (Post 5659307)
You may be interested to know the testing-only version 1.5.3 compiled on my system and has the spell checker. It is under the 'Extras' menu now and is still able to be invokes with Shift+F7.

Hi...

That's cool, I'm assuming you able to load the dictionary and perform spell checks? :)

Quote:

Originally Posted by Doug Hutcheson (Post 5659307)
So what is wrong with my 1.4.6 version?

Absolutely no idea, unless it's what beachboy2 suggested with respect to Fedora. Or it may be something wrong with the particular package available in Fedora's repositories. :scratch:

Regards...

Doug Hutcheson 01-24-2017 05:00 PM

I have tracked down the immediate cause: the version of 1.4.6 in the Fedora 25 repository does not include libhunspellplugin.so

Now the question is "why"? It is present in the Fedora 24 version and in the latest 1.5.3 testing-only version I compiled.

I have loaded F24 into a VM and will try to get the file from there into my normal F25. I tried copying the 1.5.3 version of the file into 1.4.6, but Scribus couldn't load it.

I love problems like this - not!

Doug Hutcheson 01-25-2017 12:21 AM

Fedora 25 Scribus 1.4.6 cannot use the libunspellplugin.so from Fedora 24 or from Scribus 1.5.3.

Attempting to install the F24 Scribus 1.4.6 caused dnf to offer to delete 274 applications, so I chose not to do that!

I am left with Scribus 1.4.6 with no spell checker on Fedora 25, plus Scribus 1.5.3 with a working spell-checker.

It would have saved a lot of work if the Fedora 25 compilation of Scribus 1.4.6 had included libhunspellplugin.so (what were they thinking?), but that is all water under the bridge.

Incidentally, I installed Chapeau in a VM and found it is based on Fedora 24, so Scribus spell-checker works there!

Linux: there is always a way around any problem. "8-)

ardvark71 01-25-2017 01:38 AM

Quote:

Originally Posted by Doug Hutcheson (Post 5659803)
It would have saved a lot of work if the Fedora 25 compilation of Scribus 1.4.6 had included libhunspellplugin.so (what were they thinking?), but that is all water under the bridge.

Hi Doug...

It probably was an oversight. Hopefully, the package maintainer (or whatever the title is) for Fedora will take note and correct it. However, I'm glad you found a solution. :)

Regards...


All times are GMT -5. The time now is 02:50 AM.