LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-16-2008, 09:06 AM   #1
crazyivan
Member
 
Registered: Mar 2007
Distribution: Debian, Ubuntu server
Posts: 40

Rep: Reputation: 15
Question Samba Win2K NT_STATUS_IO_TIMEOUT


Hello crew,

I'm having troubles with authenticating a linux samba client to a win2k domain. Without creating local users I want to be able to log on using a user and pass valid only in the windows domain.

Somehow I seem to be stuck on the last part:

When I log in with correct user and correct pass:

/var/log/pam.log
Jan 14 16:29:03 sandbox pam_winbind[2632]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 16:29:07 sandbox pam_winbind[2632]: Verify user `testuser'
Jan 14 16:29:17 sandbox pam_winbind[2632]: request failed: NT_STATUS_IO_TIMEOUT, PAM error was System error (4), NT error was NT_STATUS_IO_TIMEOUT
Jan 14 16:29:17 sandbox pam_winbind[2632]: internal module error (retval = 4, user = `testuser')

When I login using a WRONG password:

/var/log/pam.log
Jan 14 16:31:33 sandbox pam_winbind[2675]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 16:31:35 sandbox pam_winbind[2675]: Verify user `testuser'
Jan 14 16:31:35 sandbox pam_winbind[2675]: request failed: Wrong Password, PAM error was Authentication failure (7), NT error was NT_STATUS_WRONG_PASSWORD
Jan 14 16:31:35 sandbox pam_winbind[2675]: user `testuser' denied access (incorrect password or invalid membership)

When I login using `wronguser`:

/var/log/pam.log
Jan 14 17:38:43 sandbox pam_winbind[2928]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 17:38:45 sandbox pam_winbind[2928]: Verify user `wronguser'
Jan 14 17:38:45 sandbox pam_winbind[2928]: request failed: No such user, PAM error was User not known to the underlying authentication module (10), NT error was NT_STATUS_NO_SUCH_USER
Jan 14 17:38:45 sandbox pam_winbind[2928]: user `wronguser' not found


Testing the authentication using `kinit` works perfectly. `wbinfo -u` and `wbinfo -g` produce all users and groups in domain. `getent passwd` gives me only the local machines listings. I'm working with a fresh debian install. All packages are installed `out of the box`. I'm very willing to supply more info but I thought posting the entire config upfront is a little too much. I'm using Linux sandbox 2.6.18-5-686 #1 SMP Mon Dec 24 16:41:07 UTC 2007 i686 GNU/Linux
and Samba Version 3.0.24

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Authenticating Samba and Win2K NT_STATUS_IO_TIMEOUT crazyivan Linux - Newbie 0 01-16-2008 02:06 AM
samba and win2k AD / HELP!! unforgivn Linux - Networking 1 06-17-2004 07:17 AM
Samba share - network name no longer available when browsing samba from win2k dorango Linux - Software 0 03-02-2004 01:02 PM
samba and win2k term Linux - Networking 10 02-15-2002 04:15 AM
Samba and Win2K chamkila Linux - Networking 2 11-04-2001 06:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration