LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Samba / Vista / Debian 4 (https://www.linuxquestions.org/questions/linux-software-2/samba-vista-debian-4-a-619716/)

Coyote34 02-08-2008 01:25 PM

Samba / Vista / Debian 4
 
Hi, there!

I am loosing my hair. I have configured a samba as PDC. But the windows doesnīt save the profile on the server.
[global]
...
domain logons = yes
logon path = \\%L\profiles\%U
logon drive = H:
logon home = \\%L\%U
logon script = logon.bat
domain master = yes
local master = yes
preferred master = yes

[netlogon]
path = /home/netlogon
read only = yes

[profiles]
path = /home/profiles
browseable = yes
read only = no
create mask = 0600
directory = 0700
All directory as chmod 777 and also users writepermissions

rtspitz 02-08-2008 02:40 PM

---> http://us3.samba.org/samba/docs/man/....html#id352707

this might help. if I remember right, I had to meddle with said default profile to make roaming profiles work on xp pro. I also made some registry adjustments on the xp clients. if above samba book doesn't help I could have a look at my notes and or put a zip with our default profile / registry hacks somewhere to download.

Coyote34 02-15-2008 10:46 AM

No way
 
Thanks, rtspitz.

But I have tried everything. I have read something about profile.V2. I have tried on smb.conf:
[profiles.V2]
copy = profiles

But it still not working. The Windows Vista creates the folder, but he doesnīt save anything.

I told you I am loosing my hair....

COyOte34

rupertwh 02-15-2008 11:17 AM

Hi,

maybe
Code:

[profiles]
...
profile acls = yes

can help? (Make sure to read the man page about it)

rtspitz 02-15-2008 02:58 PM

oh, you're using vista... didn't say so in the first post..

We're exclusively using windows xp with samba, and we won't change that as long as possible :-)
I've never tried putting vista in our samba domain, heck until a few weeks ago the few vista notebooks we have couldn't even see our samba shares...

correction: apparently I can't read the title...

Coyote34 02-18-2008 04:16 AM

Still trying
 
Thanks, rupertwh and rtspitz.

The comment "profile acls = yes" was fine, I couldnīt acess samba even using Windows XP.

About the Windows Vista Share problem, it is easy to fix. You have to change on Windows Vista, the policie "Network security: LAN Manager authentication level" to "Send LM & NTLM - use NTLMv2 session security if negotiated".

There are many posts regarding this.

Kind regards,

Coyote

rtspitz 02-20-2008 04:46 PM

been there, done that, didn't work :-)

since the last update of samba we put on our main server, that problem was gone without any changes on the clients.


All times are GMT -5. The time now is 03:06 AM.