LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-01-2007, 01:08 PM   #1
armandino
Member
 
Registered: Oct 2005
Posts: 72

Rep: Reputation: 15
Samba simple share not working


I have shared a folder (/home/share) in a Fedora system, setting the share readable and writable to all users. The corresponding, final section in smb.conf reads:

[test]
comment = test samba share
path = /home/share
writeable = yes
browseable = yes
guest ok = yes

When I try to connect from a WinXP SP2 machine, specifying the IP address in the form "\\192.168.nn.nn", I get a request of username and password, which I thought would NOT happen, due to the last line in smb.conf

More than that, whatever username and password I enter (amongst the Fedora box users, root included), I do NOT gain access to the share. XP seems to "feel" the IP address and the shared folder, but goes on asking for username and password.

I have NOT used the smbpasswd command (thus leaving the /etc/samba/smbpasswd file empty) because I thought that I should use it only if I want samba users and passwords to be different from the ones already defined in the /etc/passwd main file. Is this assumption wrong? Is it mandatory to define samba users, even if you want them to coincide with the ones already defined in the system?

Or am I missing something else?

Thanks
 
Old 07-01-2007, 01:17 PM   #2
badall
LQ Newbie
 
Registered: May 2007
Posts: 19

Rep: Reputation: 0
If you don't want to use sambapasswd then make sure that you've disabled the passwd option in your smb.conf.
 
Old 07-01-2007, 01:33 PM   #3
armandino
Member
 
Registered: Oct 2005
Posts: 72

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by badall
If you don't want to use sambapasswd then make sure that you've disabled the passwd option in your smb.conf.
Thanks for your so quick reply.

I already checked: my smb.conf has no password options set. All the password-related lines of the file are commented (they begin with ';'). I think this should disable all smbpasswd stuff.
 
Old 07-02-2007, 12:01 AM   #4
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
In your smb.conf, set security parameter to this:
Code:
security = shared mode
That should do it. Anyone should be able to access the share.

-twantrd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Simple Samba Share acerola Linux - Newbie 3 04-29-2007 12:59 AM
anyone have a simple samba - xp setup they want to share? mdm0173 Linux - Software 4 10-06-2006 03:40 AM
Simple Samba Setup, Share & Not Share timmywo Linux - Software 4 07-30-2004 07:27 AM
simple SAMBA share true_atlantis Linux - Software 3 05-28-2004 06:44 PM
Simple Samba 2.8 Howto SHARE question.. mariusak Linux - Software 1 03-01-2004 11:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration