-   Linux - Software (
-   -   Samba shares and windows machines (

lacitpo 02-26-2005 01:49 AM

Samba shares and windows machines
I am a new linux user :) and I am loving it. I have a linux machine that I am trying to use as a file server for my windows boxes. I intend to map directories on my windows machines pointing to shares on my linux box. I am posting my smb.conf file below so that maybe someone can tell my what is wrong with it, because I have been messing with this for about 10 hours now and am getting no where. When I browse the network from one of my windows computers, I can see my linux computer, but when I try to access it I get an error saying access denied. Here is my smb.conf file.

server string = Linux Server
username map = /etc/samba/smbusers
time server = Yes
add machine script = /usr/sbin/useradd -d /dev/null -g storage -s /bin/false -M %u
os level = 65
preferred master = Yes
domain master = Yes

read only = No
create mask = 0644
guest ok = Yes

path = /home/samba/netlogon
guest ok = Yes

path = /home/samba/profiles
read only = No
create mask = 0600
directory mask = 0700
guest ok = Yes

comment = public media, read only
path = /mnt/storage/shares
guest ok = Yes

comment = emule and azureus incoming
path = /mnt/storage/p2p
valid users = lacitpo, nsdogg, nsdoggs
read only = No
browseable = No

path = /mnt/storage/
valid users = lacitpo, nsdogg, nsdoggs
read only = No
browseable = No

Micro420 02-26-2005 01:53 AM

Generic checklist:

1) did you setup user accounts on both your linux and Windows box? They have to be the same
2) do you have the same domain/workgroup in windows and linux?
3) are you able to ping both computers back and forth?
4) firewall?
5) Use smb4k as it is graphical and will help you set up samba
6) make sure your SMB services are running, along with NMB
7) make sure you are setting up your folders to share correctly. You can do this by right-click on the folder and selecting SHARE (In windows and linux). By default you cannot share outside your /home directory.

lacitpo 02-26-2005 01:56 AM

Thanks,the firewall fixed it. I owe you big

All times are GMT -5. The time now is 02:47 AM.