-   Linux - Software (
-   -   Samba Share Write permission Issues (

Colossus610 08-12-2004 02:52 AM

Samba Share Write permission Issues
Ok that's it, I've hunted thru the forums and viewed god knows how any Samba issues threads and all to no avail.
I've got a SuSE 9.0 Pro box running Samba, I can see the shares on my Windoze machines just fine, browse the contents no prob I just can't figure out how to change permissions to allow writing from the Windoze machines.
The share I'm most interested in is a second HD as hdb1 under /colossalfiles, that went ok, no problems there, got Samba to share it, I just can't write to it from Windoze.I know this may have been covered countless times before but I couldn't find anything that proved useful. I'm not really a software guy, trying to learn this Linux thing, im quite determined actually to lose my Windoze dependancy(even attended a Windoze Anonymous meeting, that went well too!)
Anyway down to business, here's my smb.conf file, any and all input into this issue of mine would be greatly appreciated by an intelligent, under-educated but trying my damndest Linux rookie.(musn't use that forsaken "Noob" word.

workgroup = MSHOME
os level = 2
time server = Yes
unix extensions = Yes
encrypt passwords = yes
map to guest = Bad User
printing = CUPS
printcap name = CUPS
wins support = No
veto files = /*.eml/*.nws/riched20.dll/*.{*}/
security = share
server string = Braian's Linux Bitch
interfaces =
add user script =
domain master = false
domain logons = no
local master = no
preferred master = auto
;; ldap server =
comment = Home Directories
valid users = %S
browseable = yes
read only = No
create mask = 0640
directory mask = 0750
guest ok = yes
printable = no
comment = All Printers
path = /var/tmp
printable = yes
create mask = 0600
browseable = no
guest ok = no
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
browseable = yes
guest ok = no
printable = no
comment = Network Storage
path = /colossalfiles
public = yes
only guests = yes
writable = yes
printable = no
create mask = 0000

P.S - Punch and Pie

david_ross 08-12-2004 12:31 PM

Which user are you connecting to the share as?

What are the permissions on that directory:
ls -la /colossalfiles

Colossus610 08-12-2004 04:54 PM

I've tried writing from Windoze machine under colossus, the same user as I'm trying to get write perm.
I've even tried changing ownership of the directory while under root, but it says i don't have sufficient access to files to do so.
i hope i did this right, but here
drwxr-xr-x 8 root root 8192 1969-12-31 18:00 .
drwxr-xr-x 21 root root 496 2004-08-12 02:29 ..
drwxr-xr-x 19 root root 8192 2004-08-12 01:39 Braian's Folder
drwxr-xr-x 19 root root 16384 2004-08-12 01:30
drwxr-xr-x 7 root root 8192 2004-08-05 04:40 Command and Conquer Generals Zero Hour Data
drwxr-xr-x 10 root root 8192 2004-08-05 04:58 Downloads
-rwxr-xr-x 1 root root 248517 2004-08-05 04:52 explodegreen.jpg
-rwxr-xr-x 1 root root 153827 2004-08-05 04:52 explodegrey.jpg
-rwxr-xr-x 1 root root 96155 2004-08-05 04:52 explode.jpg
-rwxr-xr-x 1 root root 214320 2004-08-05 04:52 explodeprple.jpg
-rwxr-xr-x 1 root root 211469 2004-08-05 04:52 explodered.jpg
-rwxr-xr-x 1 root root 260977 2004-08-05 04:52 explodeyellow.jpg
drwxr-xr-x 6 root root 8192 2004-08-05 04:51 Favorites
drwxr-xr-x 4 root root 8192 2004-08-05 02:15 InterVideo

I've tried right clicking on the directory and checking the write permission boxes but the changes never stick
forgive but I'm am really a Linux rookie, am really new to the whole command thing and still learning how to navigate thru stuff.

david_ross 08-12-2004 05:07 PM

If you are connecting as the user colossus then the files need to be writeable by colossus - the easiest way to change this would be:
chown -R colossus /colossalfiles

If you run the ls command after that you should see that the owner has changed to colossus

Colossus610 08-12-2004 05:20 PM

Under colossus or even root it scrolled thru each file trying to change permisions then for each said operation not permitted.
I think I may need to get one of those "Linux for dummies" books.
But I am determined to crack this Linux thing and thereto crack my Windoze crutch.

I dont think I should even say "crack" this Linux thing, I've had no issues but this permissions thing, other than that I've enjoyed the new experience and look forward to trying other distros.

All times are GMT -5. The time now is 12:16 AM.