LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-03-2005, 02:53 PM   #1
Phaethar
Member
 
Registered: Oct 2003
Location: MN
Distribution: CentOS, Fedora
Posts: 182

Rep: Reputation: 30
Samba share not working right with Excel 97


Hey all,

We're having some trouble saving Excel documents on our Samba Fileserver. We are moving people over to our Samba box, and have moved most of our documents over. Now, we have people opening their Excel documents, but are unable to save them. When something is saved, we see this message:

Code:
Your changes could not be saved to 'document.xls', but were saved to a temporary document named '349rgjh928'. Close the existing document, then open the temporary document and save it under a new name.
Now, these users have full access to the folder in which they're trying to save these sheets. New documents can be created an deleted without any problem, so it doesn't appear to be a permissions problem. However, if I manually set the document owner to the user trying to save the document, it seems to save without a problem. Of course, this isn't a viable option, as we have multiple people accessing these documents all the time, and as a group, they have full access to these folders.

So, I'm wondering what I can do on this system to resolve this issue. I know we're using an old version of Excel, but it still works for what we need. Our version of Samba is 3.0.10-1.fc2, and we are running on a Fedora Core 2 system. The clients connecting are using Windows XP Home, and have Excel 97 SR-2.

Any ideas on what I can do to clear this up? I can post config files if needed, but as of right now, it's almost the default with just the share volume set up.

Thanks!
 
Old 03-03-2005, 04:57 PM   #2
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
Are you using security=user? If so, are you doing a "map network drive" on the Winsoze box, or are you merely browsing in via network neighborhood?

Is your Samba box set to be a browse master? A domain master? A WINS master?
 
Old 03-04-2005, 07:10 AM   #3
Phaethar
Member
 
Registered: Oct 2003
Location: MN
Distribution: CentOS, Fedora
Posts: 182

Original Poster
Rep: Reputation: 30
Jiml8,

I'll try to run through your questions here:

Yes, we are using security=user.
We are mapping network drives on all of the Windows boxes.
The Samba box is not set up as a browse master, a domain, or for WINS.

This issue only seems to come up with Excel documents, but there isn't any good reason for it to happen that I can see.

If you need any other information, just let me know.

Thanks!
 
Old 03-04-2005, 08:08 AM   #4
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
Quote:
This issue only seems to come up with Excel documents, but there isn't any good reason for it to happen that I can see.
I am wondering if Excel is timing out trying to read the file. Are you getting good, snappy response from Samba on opening windows and files?

I had a problem here with very slow response using security=user and I made a lot of progress by making the samba server a domain master, a wins master, and a browse master. Now, when a samba share is mapped as a network drive, the response is just fine.

Just a suggestion, and it pretty much exhausts my ideas on the topic.
 
Old 03-04-2005, 03:45 PM   #5
Phaethar
Member
 
Registered: Oct 2003
Location: MN
Distribution: CentOS, Fedora
Posts: 182

Original Poster
Rep: Reputation: 30
Hey Jiml8,

Thanks for your suggestions with this. I've been testing this on and off again today, and the timing for bringing up these (or any) files is very quick. I don't believe it is an issue where something is timing out, but it might be worth trying to set it up as a browse master anyway

Also, just as an update, I tried setting up a FC3 system with Samba 3.0.11 to see if that would do anything differently. I also tried using OfficeXP to see if this was caused by using an old version of Excel. Unfortunately, I still get the same thing. Excel words the error a little differently, but it does the same thing, that being it saves a temp file but can't replace the original.

This is definitely a Samba issue, I'm really just hoping there is a way I can get around it.
 
Old 03-04-2005, 04:50 PM   #6
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
I am running Samba 3.0.11 on a Mandrake installation, and just to try it, I fired up Excel 97 in a Win2K installation running in VMWare on the same Mandrake system. I then placed an xls file on a Linux share that is shared across my LAN using Samba.

I read the file using Excel 97, edited it, and wrote it without trouble. To verify that this was not some artifact of VMWare, I moved to another machine on my LAN (another Win2K box), accessed the share with Excel 97, loaded the file, edited it, and saved it without trouble.

Why don't you post your smb.conf, with the global info and the info on the particular share.
 
Old 03-07-2005, 08:29 AM   #7
Phaethar
Member
 
Registered: Oct 2003
Location: MN
Distribution: CentOS, Fedora
Posts: 182

Original Poster
Rep: Reputation: 30
Ok, here is the smb.conf file. Some of the share settings are redundant, but better safe than sorry, right?

Code:
[global]
   workgroup = Production
   server string = Fileserver

   printcap name = /etc/printcap
   load printers = yes
   cups options = raw
   log file = /var/log/samba/%m.log
   max log size = 50

   security = user

   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

   dns proxy = no

#============================ Share Definitions ==============================
[homes]
   comment = Home Directories
   browseable = no
   writable = yes
   valid users = %S
   create mode = 0600
   directory mode = 0600

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes

[Share1]
   comment = Share1
   path = /folder1
   valid users = @accounting,@sales,@dataentry,@operations
   public = no
   writable = yes
   printable = no
   create mask = 3660
   directory mask = 3770
In your testing, you weren't possibly logged in as the owner of the Excel file, were you? That seems to be the only way I can allow a user to save their files is by changing them to be the owner of the file. Then, everything works as it should. This problem only shows up when they're trying to save a file and are not the owner, even though they are in the group that should have full access.

Thanks for all your help with this so far!

EDIT: I'm now seeing that users are unable to delete files as well, unless they are specifically set up as the file or folder owner, which is very difficult in an environment where so much is shared. If they are the owner, the file deletes just fine through Windows explorer. If they are not the owner (but still have full access by group) they can delete the file through Windows explorer just fine, but the file comes right back on a refresh. No errors... it just doesn't get deleted. I'm thinking this may be related to the Excel problem, but I have no idea why we can't delete files.

Last edited by Phaethar; 03-07-2005 at 10:21 AM.
 
Old 03-07-2005, 10:26 PM   #8
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
Quote:
In your testing, you weren't possibly logged in as the owner of the Excel file, were you? That seems to be the only way I can allow a user to save their files is by changing them to be the owner of the file. Then, everything works as it should. This problem only shows up when they're trying to save a file and are not the owner, even though they are in the group that should have full access.
I was almost certainly the owner of the xls files I was looking at.

I will bet your group definitions are inconsistent between samba and your windows clients. Your allowed users definitions will test NIS group definitions first, then Unix group definitions. Do you have NIS running?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba share working intermittently - don't know why swampdog2002 Linux - General 3 08-23-2005 07:54 AM
excel 2003 slow in samba kenji1903 Linux - Networking 0 04-15-2005 08:36 PM
Samba share stops working after reboot FunFactor100 Linux - Software 1 04-08-2005 10:41 PM
Mounting samba share not working nmares Linux - Software 2 10-19-2004 10:47 PM
Simple Samba Setup, Share & Not Share timmywo Linux - Software 4 07-30-2004 07:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration