-   Linux - Software (
-   -   Samba requires authentication to browse unsecured Windows shares (

shultzc 05-07-2004 02:24 AM

Samba requires authentication to browse unsecured Windows shares

I did a quick search for a question like this one, but came up empty-handed. If this has already been answered, direction to the appropriate thread would be appreciated....

I am a reasonably competent Linux user running Fedora Core 1 on an Athlon with samba-3.0.0-15 installed from RPM as supplied in the original install image. Though I have used Linux continuously for several years, this is my first attempt at getting samba running, so please pardon my ignorance.

In short, I want to be able to access Windows shares, especially certain public shares that are set to not require a user name and password.

I have modified my smb.conf file to list the correct Windows Workgroup designated by my university and have initialized the samba service by running "/etc/init.d/smb start" as root. The remainder of the smb.conf file was left unchanged, including the security level. (This only has to do with the local SMB server, not client, right?)

By running "Network Servers" from the RedHat/Start menu in GNOME, I see various workgroups, including the one that I wish to browse. Inside the workgroup are all the Windows servers that should be present. However, when I try to browse volumes on ANY Windows server, including those that I know for a fact do NOT require a user name password (when accessed from a Windows machine), I am prompted for a name/password. I have been unable to figure out how to get around this, since these servers simply have no user names or passwords associated with them.

If anyone could suggest how to let me browse freely shared volumes on Windows machines, I would greatly appreciate it; I hate having to go to the computer lab to download homework assignments from share servers.


Conrad Shultz

sorrodos 05-07-2004 02:49 AM

Probably dumb to ask this, but do you have guest logins enabled...? I know its not necessary

It probably wouldn't hurt to post your smb.conf :)

shultzc 05-07-2004 03:08 AM

Thanks for responding.

I presume that by guest logins being enabled you are referring to the servers to which I am trying to connect. I do not administer the servers in question. All I know is that these servers I ordinarily do not have to supply credentials for, whereas for other campus servers I do have to supply credentials. I.e. the server volumes in question are public read-only.

My smb.conf file (non-commented sections) is pasted below.


workgroup = REED
server string = Samba Server
printcap name = /etc/printcap
load printers = yes
log file = /var/log/samba/%m.log
max log size = 50
security = user
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
comment = Home Directories
browseable = yes
writable = no
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes

vectordrake 05-07-2004 06:57 AM

This may be of little help, but I have never set any permissions when I set up my home network. I was too lazy to remember the samba syntax, so I used Linneighborhood (a GUI network browser). To access a share, I chose to "browse as user" and hit enter - as in no password. I can read/write between both machines that way. From the WindowsXP box, I can browse the shared folder on my Mandrake machine and vice-vera.

So, you may already be able to access the userless/passwordless shares without knowing it. Try to browse as user (use your user from the machine you're on) and don't enter a password. It might work (doesn't teach you anything, really, but if it works...)

shultzc 05-07-2004 02:12 PM

Thanks, but I tried that and it didn't do the trick.


MS3FGX 05-07-2004 02:52 PM


guest ok = yes
guest only = yes

In the share you want to be public should work, if that doesn't work, change

security = user


security = share

And try again.

sorrodos 05-07-2004 03:12 PM

shultzc, I misread your first post. I thought you administered the servers in question. Sorry about that.

What is this tool you are using to access the shares? Is it just loading in Nautilus?

You could also check out LinNeighborhood... I use KDE myself and just use Konqueror to browse such shares at home/on my campus.

Your smb.conf shouldn't actually affect you browsing the shares. That file is used for the shares you have on your own machine.

In KDE, there is a network browsing section of the Control Center, thats where I supply the credentials my university wants me to provide. I am not sure if there is an equivalent area in Gnome.

Have you tried just leaving the username and password fields blank when you try to browse the shares?

Nichole_knc 05-09-2004 06:32 AM

I to have this same issue... Linux requiring user/pass for public shares.
I have tried several options and found no fix... I figured since I was able to config samba to work across 3 networks it would be simple to stop the user/pass browsing requirement... NOPE...

gankoji 08-19-2009 12:10 PM

if you know the server name and share name of what you are trying to get to (or just the server, if it's browseable) then just go to konqueror.
in the address bar type smb://ServerName/ShareName or just smb://ServerName. konqueror supports browsing without credentials just fine.

vectordrake 08-19-2009 06:16 PM

Good advice for this dusty old thread

gankoji 08-19-2009 06:38 PM

haha no sooner than I had I posted that I noticed last post was in '04. Good to see somebody's still paying attention :-D.

All times are GMT -5. The time now is 12:07 AM.