LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Samba public share (https://www.linuxquestions.org/questions/linux-software-2/samba-public-share-382171/)

FNC 11-11-2005 12:05 PM

Samba public share
 
Hi, Can someone please help me?

I am trying to setup a samba server with a share where everyone and anyone can copy and save files. The problem is that when ever i try to access it i get asked for a username and password. I've even chanced the guest account to root, but still no use.

I have been struggling with this thing fr a couple of hours now, and don't know what I'm doing wrong.

Here is my smb.conf file:

[global]

workgroup = NIP
server string = Linux Server
netbios name = neptune
encrypt passwords = yes
log file = /var/log/samba-log.%m
max log size = 50
os level = 65
preferred master = yes
wins proxy = yes
security = SHARE
hosts allow = 10.0.0. 127.

guest account = root


[public]

path= /mnt/data
comment = public
read only = No
public = yes
browseable = yes
guest ok = yes

Any help would be greatly appreciated.

gizmobay 11-11-2005 01:54 PM

You trying to share with other Linux boxes or with a Windows box?

FNC 11-11-2005 02:39 PM

Windows box's - Mostly XP and 2k

Die Woud 11-11-2005 02:57 PM

did you add it to smbpasswd?

FNC 11-11-2005 03:02 PM

I did, I even added a new user named smbguest, but still i get asked for a username and password. I am using FC2 - if that helps?

gizmobay 11-11-2005 07:13 PM

I would save a copy of your smb.config. From there, I would take the default smb.confg and add

[public]

path= /mnt/data
comment = public
read only = No
public = yes
browseable = yes
guest ok = yes

Then replace the old smb with the edited default

Once you get that working, I'd tweak the smb file little by little until it meets your needs. This is what I did to make mine work after hours of trying to start from scratch with an smb file.

wym 11-11-2005 09:22 PM

Try this,

[global]
# guest account = root
security = share

and then, /mnt/data should be at least drwxr-xr-x

FNC 11-12-2005 03:24 AM

Thanks for the reply, but i still get a username and password box when I try to connect.
I'm frustrated I feel like formating this box and loading RH9
:scratch:

jschiwal 11-12-2005 04:50 AM

Here is an sample from "Samba 3 by Example". If you have swat installed then you may have this book on your computer at:
http://localhost:901/swat/help/Samba...html#id2531126
I highlighted a couple lines. The force group and force user options are what I think that you are missing. You don't want the user/group to be root. It is common to use the user "nobody" to remove many permissions.

Code:

Example 2.2. Charity Administration Office smb.conf File
# Global Parameters
  [global]
  workgroup = MIDEARTH
  security = SHARE
  printing = CUPS
  printcap name = CUPS
  disable spoolss = Yes
  show add printer wizard = No
  wins support = yes
  [FTMFILES]
  comment = Funds Tracking & Management Files
  path = /data/ftmfiles
  read only = No
  force user = abmas
  force group = office

  guest ok = Yes
  nt acl support = No
  [office]
  comment = General Office Files
  path = /data/officefiles
  read only = No
  force user = abmas
  force group = office
  guest ok = Yes
  nt acl support = No
  [printers]
  comment = Print Temporary Spool Configuration
  path = /var/spool/samba
  printable = Yes
  guest ok = Yes
  use client driver = Yes
  browseable = No


martli 11-14-2005 07:54 PM

you have to change the security setting to either
security=user or security=server


All times are GMT -5. The time now is 04:44 PM.