Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-14-2002, 08:14 PM   #1
LQ Newbie
Registered: Dec 2002
Posts: 3

Rep: Reputation: 0
SAMBA frustration

Greetings fellow techies!

I tried out SAMBA on Mandrake 7.0 a couple of years ago and was able to ger it working, but this time around RedHat 8 and SAMBA loaded on a real server (I usualy use whatever junk I have laying around) has netted me nothing. It hasn't made me crazy yet, but who knows how long my brain can hold out!

Preliminaries: I loaded absolutely everything as I have plenty of space. The server and test client get IP addresses from a Win98 box running ICS (junk, but dumping that is phase 2). Both boxes see out to the internet as I can browse from both. Any box can ping any other box on my local net. I have created my users and assigned passwords in Linux and Samba.

Symptoms: Before I put the server and client on their own workgroup I was able to see the server name but not browse any shares or map to them. after changing the workgroup name for both clients I get semaphore timeout errors on the client and do not see the server name in network neighborhood.


# Samba config file created using SWAT
# from UNKNOWN (
# Date: 2002/12/14 12:36:11

# Global parameters
workgroup = SHEEP
netbios name = STORM
server string = Samba Server
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
os level = 60
preferred master = True
dns proxy = No
hosts allow = wool spring ewetoo hightide ram
printing = lprng

comment = Home Directories
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

comment = Shared Family Stuff
path = /home/public
valid users = kerryl kira patricia
read only = No

comment = Kerry's Private Directory
path = /home/private
valid users = kerryl
read only = No

Any ideas

Last edited by Riptide; 12-14-2002 at 08:16 PM.
Old 12-14-2002, 09:48 PM   #2
LQ Newbie
Registered: Dec 2002
Posts: 3

Original Poster
Rep: Reputation: 0

I am now getting account not authorized to login from this station.

I moved client to static IP and put that IP in the /etc/hosts file.

any ideas?
Old 12-14-2002, 11:14 PM   #3
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
have you read the smb.conf that was includesd in the package of the samba server? (man smb.conf)

check hosts_access for more info about hosts allow

Instead of read only try with wribale

writable = yes

I think that the arguments after = are to be serpareted by , like this:
valid users = greg, pete, java, netkill
in the global part of the script try adding a line
security = share
and then ckeck if you can access the shares

after that set it to
security = user
report back your status after doing all that.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA-frustration jrcreasy Linux - Newbie 6 08-25-2005 07:18 AM
Ipod frustration. drbroccoli Linux - Hardware 1 07-27-2005 02:49 PM
sound frustration Th3_J3st3R Slackware 9 07-18-2004 04:27 PM
Samba frustration debest Linux - Networking 5 08-08-2003 11:29 PM
Telnet Frustration Breezwell Linux - Networking 6 08-16-2001 04:03 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration