LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-15-2008, 09:09 AM   #16
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30

You are not alone. I have the exact same problem and this thread is the only lead that Google is coming up with. This has been happening to our server for years, but on a much smaller scale than your's.

We're running samba-3.0.25b on CentOS 5 with kernel 2.6.18-53.1.4 and are using the system as an Active Directory member server, complete with file system acl and xattr support on the file system being served by samba.

I've tried disabling kernel oplocks, but it didn't help.

The system is serving ghost images to our staging department, and seemingly at random, running MSDOS executables off the server will freeze up the workstation for several minutes and will generate this error:

smbd/oplock.cplock_timeout_handler(356) Oplock break failed for file FOO.EXE -- replying anyway

To further complicate things, our ghost images are loaded from an MSDOS-based network PXE image loaded on each given workstation, so we're using the old DOS networking software with NDIS2 drivers on the clients to access the samba server.

This is a real productivity hit to us and I'd really like to see it resolved.
 
Old 06-24-2008, 01:57 AM   #17
Astol
Member
 
Registered: Aug 2007
Location: Perth, Australia
Distribution: RHEL 5 + 4.5, Fedora
Posts: 88

Original Poster
Rep: Reputation: 15
you and me both. my freezing problems have gone, it was a totally different problem to what i thought, i have a link to my blog below, which i posted my solution, but im still getting the entries in the logs...

http:// anerdlikeme.blogspot.com /2008/03/ my-freezer-solution. html

you will need to remove the spaces for it to work, cos i dont want spam plus im not sure LQ lets you post external links...

can you post your smb.conf and logs?
 
Old 09-16-2008, 09:10 AM   #18
Yerosnimus
LQ Newbie
 
Registered: Sep 2008
Location: FRANCE
Distribution: Mandriva 2008
Posts: 7

Rep: Reputation: 1
Hello,

I've the same problem thant Astol, 3 samba's server freeze when many and heavy I/O operations run.
I think it could be a Raid problem (Raid 5) may be the controller (PERC 4e) but i'm not sure.
Astol, have you found an issue about your problem ?

Best regards

Jerome
 
Old 11-04-2008, 06:32 PM   #19
stangdano
LQ Newbie
 
Registered: Feb 2006
Distribution: CentOS 5
Posts: 6

Rep: Reputation: 0
Thumbs up

I just had the same problem. I was able to get my issue fixed by updating the DNS servers that the SMB server uses. If the nameserver where you are directing it doesn't reply to DNS requests, the server times out trying to do reverse name resolution when the client connects.
At least that's what I'm thinking judging by my results after pointing to a valid DNS server.
 
Old 11-05-2008, 08:56 AM   #20
Yerosnimus
LQ Newbie
 
Registered: Sep 2008
Location: FRANCE
Distribution: Mandriva 2008
Posts: 7

Rep: Reputation: 1
Quote:
Originally Posted by stangdano View Post
I just had the same problem. I was able to get my issue fixed by updating the DNS servers that the SMB server uses. If the nameserver where you are directing it doesn't reply to DNS requests, the server times out trying to do reverse name resolution when the client connects.
At least that's what I'm thinking judging by my results after pointing to a valid DNS server.
Thank you for this clue but we don't use DNS with samba (DNS Proxy = no)?

Thanks again

Best regards

Jerome
 
Old 02-11-2009, 01:34 PM   #21
hirsch
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Astol View Post

If you have the same problem, or any possible solutions, let me know
I have the same problem here, since updating from sarge over etch to lenny, samba freezes all clients in 1-10 min intervalls.

i think its a lenny bug, because, with an old sarge server (that hold simulare date) dont show this.
its also possible that this is a bug of the kernel i use, because with lenny its 2.6.27.10 and with sarge it was 2.4.37

i have tuned all settings of samba, but i dont think its the config samba- i think its a problem with the samba used in lenny

update on this post
it looks like its a problem with samba
http://www.nabble.com/Bug-509428:-li...d21125510.html


marco

Last edited by hirsch; 02-11-2009 at 01:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba PDC - urgent help please bg108 Linux - Newbie 6 11-30-2007 01:48 PM
Urgent! - SAMBA Permissions Dmjmusser Linux - Networking 2 01-29-2006 12:17 PM
Windows Apps freeze when printing to network samba + cups printer urzumph Debian 1 02-17-2005 06:38 PM
samba share urgent Tinku Linux - Software 9 08-20-2004 09:35 AM
Urgent help !! regarding samba ! chuck77 Linux - General 5 12-06-2001 09:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration