Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-14-2004, 04:20 AM   #1
LQ Newbie
Registered: Apr 2004
Location: UK
Distribution: fedora
Posts: 4

Rep: Reputation: 0
Samba File share locking problem

I'm hoping to migrate from novell to samba purley for file sharing.

The server is a 3ghz amp athlon running on a raid 10 arrarry with 2gb of ram.

Installed is SUSE 9.0 (9.1 was not availiable when we started this project) with samba 2.2 sharing of a reiserfs partition. I also have acl support enabled.

My problem is this

If i open an ms access database on on machine a can read and write to it but if another user opens it on another machine i get an error. i have been using multiuser ms access applications for years on various types of server an not had this problem.

I have tried oplocks = no and veto oplock files =\*.mdb\ in my smb.conf but still no good.

any help very much appreciated.
Old 07-14-2004, 08:42 AM   #2
LQ Newbie
Registered: Jul 2004
Posts: 29

Rep: Reputation: 15
Are you sure that the problem is within SAMBA and not within you Windows Clients?

Perhaps debugging output of samba could help by using the following parameters in smb.conf:

log file = /var/log/samba/samba.log
log level = 3
which should produce a lot of logging to the file. If this is still not enough, increase the value!
Old 07-14-2004, 09:09 AM   #3
LQ Newbie
Registered: Feb 2004
Location: New York
Distribution: Redhat 7-9
Posts: 12

Rep: Reputation: 0
locks on a db

I remember reading that you should never use locking with any database file. Maybe you should specify no locking for that share. I am not sure what the actual option is "oplocks = no" maybe?
Old 07-14-2004, 09:14 AM   #4
LQ Newbie
Registered: Feb 2004
Location: New York
Distribution: Redhat 7-9
Posts: 12

Rep: Reputation: 0

I think the proper way would be to disable oplocks for certain types of files globally. "veto oplock files = *.db *.xls *.etc"


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba OS X to Linux Samba file share error ttoomey Linux - Software 1 08-16-2005 10:12 AM
file locking problem with samba mpriddy Linux - Software 4 11-29-2004 04:00 PM
Samba / File locking question mfeoli Linux - Networking 5 04-13-2004 04:06 PM
File locking over Samba rtaft Linux - Software 0 12-30-2003 11:02 AM
Changing file permissions on a SAMBA file share apenney Linux - Software 0 02-11-2002 04:42 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration