LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-07-2006, 06:10 AM   #1
AcidDragon
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 0
Samba configuration


I have installed Fedora Core 5 with Samba. I can see the shares from my windose boxes and when I try to connect to the share it prompts me for my user and password, I enter the user and password I have set up on linux but it just prompts me again. In the /var/log/samba log file for the remote machine it says I do not have permission to connect to the directory.

The user I am suppling is the owner of that directory.
I did do the smbpasswd to set the password for the user and the user is a valid linux user as I have logged onto the linux box with it.
I would like it to do the authentication on the linux box. I have configured it to be a standalone server with user authentication.

Any idea as to what could be wrong.
 
Old 05-07-2006, 10:25 AM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 65
Did you set in the /etc/samba/smb.conf to except encryted passwords?
If not unrem that line and restart the samba service.

Brian1
 
Old 05-07-2006, 11:51 AM   #3
AcidDragon
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
The accept encrypted passwords is set.
 
Old 05-07-2006, 12:38 PM   #4
AcidDragon
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
My config file is as follows:

[global]
workgroup = HOME.NET
server string = FileServer
netbios name = fileserver
security = user
encrypt passwords = yes
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
local master = yes
preferred master = yes
os level = 65
dns proxy = No
ldap ssl = no
hosts allow = 192.168.0., 192.168.1., 192.168.2., 127.
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[helen]
comment = Helen's Documents
path = /documents/helen
valid users = helen, hendry
write list = helen, hendry
read only = No

[hendry]
comment = Hendry't Documents
path = /documents/hendry
valid users = hendry, helen, root, AcidDragon
write list = helen, hendry
read only = No


I don't have a domain controller nor do I want one. I want it to take the user i pass it when trying to connect and validate it agains linux /etc/passwd.
 
Old 05-07-2006, 12:54 PM   #5
baskar_k
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Rep: Reputation: 1
Hi,
Whether the directory /documents/helen and /documents/hendry are owned by the those users.

Cheers,

(K.BASKAR)
 
Old 05-07-2006, 04:27 PM   #6
AcidDragon
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
yes, /documents/helen is own by helen, and /documents/hendry is own by hendry
 
Old 05-07-2006, 06:38 PM   #7
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 65
Can you connect to the samba share from the server itself?
Is there a firewall active? Disable firewall and selinux.
Use the command line on the windows box to connect and post the errors.

Brian1
 
Old 05-08-2006, 06:15 AM   #8
baskar_k
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Rep: Reputation: 1
Hi,
How about the users profile, how it has been set.

cheers,

(K.BASKAR)
 
Old 05-08-2006, 03:59 PM   #9
AcidDragon
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Disabled selinux and now it works.

Thanks for all your input.
 
Old 05-09-2006, 03:47 AM   #10
hold_breal
Member
 
Registered: Dec 2005
Distribution: suse/lfs/ubuntu
Posts: 46

Rep: Reputation: 15
aciddragon said:
I have installed Fedora Core 5 with Samba. I can see the shares from my windose boxes and when I try to connect to the share it prompts me for my user and password,


if i read this correctly, this is a problem with the samba-client on linux, not the samba server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Configuration randy1970 Linux - Newbie 5 07-24-2005 10:22 AM
Samba Configuration EzehM Linux - Networking 6 06-24-2004 03:46 PM
Samba configuration littlegreenman Linux - Networking 14 09-10-2003 12:55 PM
Samba configuration cyrilbritto Linux - Networking 3 09-02-2003 09:43 AM
Need your help on SAMBA configuration vwhk Linux - Software 4 01-14-2002 07:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration