-   Linux - Software (
-   -   Samba Config not working setting up user shares. (

cogs_bobv 10-11-2005 11:37 AM

Samba Config not working setting up user shares.
Hi all,

I'm running RH 9.0
Samba Config 1.0.4-1

Here is the problem. I tried using Samba Config to set up Samba. It properly changed /etc/smb.conf for the server name.

When I set up the shares and added a user only to be allowed to access this share, it did not work. I could not access the share from my WinXP machine.

The user shows up in Samba Config (SConfig) utility as allowing this person to be the only one for the share, but it does not add this information to smb.conf.

I go out of SConfig and come back in and the user is still set up for the share.

So, where is SConfig getting this information if it is not in /etc/samba/smb.conf??
I searched my system for another smb.conf and nothing. I confirmed by changing the server name that SConfig is changing /etc/samba/smb.conf.

I went in an manually entered it in smb.conf and my share now works, testparm says everything is OK.

Any ideas?

I would really like to use Samba Config instead of vi.

Thanks in advance

-- Bob V.

Gort32 10-11-2005 11:43 AM

testparm might give you some additional insight

cogs_bobv 10-11-2005 11:47 AM

Hey Gort32,

Tried it. Told me everything was fine. Before and after I added the user to the share using vi.

-- Bob V.

michaelk 10-11-2005 12:15 PM

I am unfamilar with this utility. Was it installed with RH9?

cogs_bobv 10-11-2005 12:21 PM

Hi MichaelK,

Samba Config came with RH9.

It's installed under Add/Remove Applications or Pacakages.

Then under Server Configuration Tools, you choose redhat-config-samba.

On the desktop/start menu, it shows up as Samba Server.
The package installed is Redhat-Config-Samba-1.0.4-1

Take care,

-- Bob V.

michaelk 10-11-2005 12:35 PM

Doh, I finally woke my brain up...

I assume you are running it as root?

cogs_bobv 10-11-2005 12:43 PM

Hi Michael,

Correct , running it as root.

-- Bob V.

michaelk 10-11-2005 04:02 PM

AFAIK the only configuration file is the /etc/samba/smb.conf. There could be bugs in this version. Make sure your using the ok button. I don't remember any bugs but it has been a long time since I've played with RH9.

BTW there are other GUI configuration utilities. swat, webmin and several others listed on the samba website.

cogs_bobv 10-11-2005 04:24 PM

Hi Michael,

I saw them. Which GUI config tool/utility would you recomend?

Thanks in advance,

-- Bob V.

michaelk 10-11-2005 08:58 PM

swat is just for configuring samba.
webmin is for configuring the OS in general.

They are web based and both do a good job. If all you need is samba then go for swat. If you want more then go for webmin.

All times are GMT -5. The time now is 04:27 AM.