LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   samba can't get share to work (https://www.linuxquestions.org/questions/linux-software-2/samba-cant-get-share-to-work-285616/)

dtra 02-03-2005 12:42 AM

samba can't get share to work
 
hi all

ok, so we have a share setup on our redhat9 devserver
that is used as our web development box

i wanted to create a share for this network folder that we currently have on a windows machine
but we need to move it because that computer is about to blow

i created a user and group (eg. winshare) to login into, and a directory for the share
and added an entry into this file /etc/samba/smb.conf

exactly the same as the other one, except path and users is different

but when i try to connect to this share via windows
it just keeps showing the login prompt
i'm sure the password is correct, as i can login directly to the linux box with the password and username

can anyone help me?

thanks
dave

BinaryBob 02-03-2005 04:12 AM

What did you use to set up the user? And did you set the permissions on the directory correctly? Can we see your smb.conf?

ScooterB 02-03-2005 08:53 AM

I am not sure but I think you have not added the user to the smb user file. It is totally different than just adding a user on the box itself. You do need to add the user to the box, but the user also needs to have a smb account. To do that, at the command prompt type "smbpasswd -a newusername" . Newusername is the user name that you want to add. It will ask you for their new password, which is typically the same password that they use to sign on their Windows box. Try that and repost.

dtra 02-03-2005 05:35 PM

hi guys, thanks for the replies

Scooter, i tried what you said, but it's the same thing when i try to log in through windows
i took the password off, but that did not work either

Code:

[http]
        path = /http
        writeable = yes
        valid users = user
        oplocks = False
        level2 oplocks = False

[sharedir]
        path = /sharedir
        writeable = yes
        valid users = shareuser
        oplocks = False
        level2 oplocks = False

where http works, and sharedir does not

the directory permissions are exactly the same for both directories

BinaryBob 02-03-2005 09:27 PM

try removing shareuser with smbpasswd -x and then readding him. Use a password, casue sometimes it acts funny without one.

Also, when you go to test it from windows, access the share you are having trouble with first, before the one that works. Becasue you have different users setup for the diferent shares windows may store the first user and attempt to re-use it for the 2nd share.

G/L

dtra 02-03-2005 09:52 PM

hmmm.... not sure what is wrong
i can only seem to connect to one at a time
if i disconnect both, then map one, i can't map the other one
the first one works, but the second one does not

DeGaR 02-03-2005 10:39 PM

Hi

I have a similar problem

Windows XP on the one side fedora 3 on the other. I can browse the windows network just fine from Linux, but not the other way around, firewalls are turned off on both sides.

I have shared a directory using samba, also set up a user account the same as my windows one, and allowed samba access to it, and restarted samba afterword. I also checked the services and samba is running.

Vnc works perfectly from windows to linux, and the other way around. and i can control linux from windows using putty.

It has to be something simple, but i don't know what.

And just to answer your question, Yes i am new to this, and i don't know what i am doing, probably been in the windows world too long.

dtra 02-04-2005 12:52 AM

mate i'm sure you are new to this, as am i
but that's no reason to hijack my thread :)

ScooterB 02-04-2005 09:42 AM

dtra, post your smb config file and lets have a look at that.

Cagao 02-04-2005 11:29 AM

dtra, I have the same problem, wanting to be able to access many different users home directories on Linux from XP at the same time, I don't think it's possible at all.

Would it be possible if the security options were removed? or changed from User? There's only me on my network, but i like to keep all my work projects under seperate users on my Linux box.

Cagao 02-04-2005 11:51 AM

Right, here's a solution (well a work-around anyway), it works for me after 2 days of trying! Mandrake 10.1 (192.168.1.1) and XP client (192.168.1.3).

smb.conf...

[global]
server string = Samba Server %v
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
ldap ssl = no
printer admin = @adm
hosts allow = 192.168.1.2, 192.168.1.3

[share1]
comment = Rob Directory
path = /home/rob
valid users = rob
username = rob
writable = Yes
read only = No

[share2]
comment = MAHunter Directory
path = /home/mahunter
valid users = mahunter
username = mahunter
writable = Yes
read only = No

[share3]
comment = UJJ Directory
path = /home/ujj
valid users = ujj
username = ujj
writable = Yes
read only = No


Now in XP, find your 'hosts' file located in 'C:\WINDOWS\SYSTEM32\DRIVERS\etc'

add entries for your server but with many different aliases, mine is...

127.0.0.1 localhost
192.168.1.1 server1
192.168.1.1 server2
192.168.1.1 server3

Now map a drive to \\server1\share1 and use one username/password.

Map another drive to \\server2\share2 (click the 'use different username' link when mapping the drive, to enter the other user credentials).

Everytime you log into XP, and try to access each mapped drive you will be asked for the corresponding password, but only once until you exit XP again, so you've got access to them while you work, and can switch around without having to enter the username/password each time.

As I say, it's just a work-around suggested on a different thread, but can't find that one now, or who suggested it.

Hope it works for ya.

Rob

DeGaR 02-04-2005 07:34 PM

Sorry dude

Wasn't trying to steal your thread, but i did get my problem solved...was a simple thing, as i suspected.

dtra 02-07-2005 08:09 PM

awesome
thanks cagao, don't really care if it is a workaround
as long as it works, that's good enough
degar, hope you learnt your lesson, but all is good when problems are solved :)

csr 02-10-2005 02:11 PM

I have samba and I can share Linux files to Window XP, but when I want exporer window xp shared files with konqueror in suse 9.0, I get a error: "Unable to find any workgroups in your local network". I have revised configuration and I don't see problems. The workgroups is correct, "INICIOMS".

Help.
Thanks.

ScooterB 02-10-2005 04:54 PM

I am not familiar with SUSE so I can't speak on thast one, but if you have all of your workgroups and subnets correct, the SUSE box should be able to see all the other linux boxes.


All times are GMT -5. The time now is 12:37 AM.