-   Linux - Software (
-   -   Samba blew my passwd? (

oneiltj 01-17-2003 12:14 PM

Samba blew my passwd?
Life was good until I attempted to make my Samba machine a domain controller. Now I can't login to the linux side ( console) with any accounts. It's like my passwd db was nuked.

I logged in using grub to single user mode and did a passwd on root and another account to no avail. what did I do to my self? I think the message was unknown password.

Anyone have any suggestions?

Thanks in advance.

wrappingupbulletholesinfoot :-(

unSpawn 01-17-2003 12:48 PM

What's in the logs?

oneiltj 01-18-2003 01:47 PM

I didn't have the presence of mind to look there. ( feeling pretty dog gone foolish ) I was in a bit of a panic. It seems that 10 minutes before I made the change that sent me up the river I called my customer and told him I would deliver the box in the afternoon. ouch

I fixed it. The hard way. I happened across a friend last night that had some interesting insight:

When I enabled Samba as a domain controller that PAM begain pointing to the smbuser file for authentication. hoseing PAM. To fix it i went to single user mode disabled pam and samba authentication, reset SU and my account. I could again login.

The default os level was 22. I changed this to 60. I'm sure this did not help. Samba again ran.

Now if I didn't hurt myself I found after I delivered the machine samba quit working and that I could not see it on the customers netowrk at all. :-( In desperation to clean any remain self inflicted bad I even un installed the samba RPMs and reinstalled. -- Better still no good. Samab smbpasswd whined about a lack of an existing passwd file in /etc. NUTS!!

A reformate and reload of rehat 8. finaly!!! fixed the problem. I have a happy(er) customer.

I have to change the dressing on my foot now. :-)

All times are GMT -5. The time now is 12:10 PM.