LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-03-2007, 08:36 PM   #1
jakob_g
LQ Newbie
 
Registered: Sep 2004
Location: Denmark
Distribution: openSuse 10.3
Posts: 26

Rep: Reputation: 15
s2ram force wont work openSUSE 10.3


I can use the s2ram -f -a3 as root, and the suspend works, but when i use the "Suspend to RAM" in the Logout menu it just restarts my wireless network... I've tried to edit the /etc/powersave/sleep but still no cigar... Here's the rellevant part of the file:

## Path: System/Powermanagement/Powersave/Sleep_Modes
## Type: yesno
## Default: "no"
## ServiceRestart: powersaved
#
# Set this variable to no to enable suspend to RAM.
# If the /usr/sbin/s2ram binary is available, it will be used to detect
# if the machine is capable of suspend to RAM. You can override this
# detection with SUSPEND2RAM_FORCE below.
DISABLE_USER_SUSPEND2RAM="no"

## Path: System/Powermanagement/Powersave/Sleep_Modes
## Type: yesno
## Default: "no"
## ServiceRestart: powersaved
#
# If /usr/sbin/s2ram is installed but does not know about your machine,
# you can force suspend to RAM for unknown machines by setting this
# variable to yes.
# Be careful, this might crash your machine.
# See also the SUSPEND2RAM_ACPI_SLEEP, SUSPEND2RAM_VBE_POST and
# SUSPEND2RAM_VBE_SAVE variables.
SUSPEND2RAM_FORCE="yes"

## Path: System/Powermanagement/Powersave/Sleep_Modes
## Type: integer(0:3)
## Default: "0"
## ServiceRestart: powersaved
#
# If SUSPEND2RAM_FORCE is set to yes and s2ram is installed, you can set
# the acpi_sleep parameter here. This is a number, 1 means "s3_bios",
# 2 means "s3_mode" 3 means "s3bios,s3mode".
# These parameters are explained in the kernel sources under
# Documentation/power/video.txt
# Leaving this empty or setting it to 0 means "don't touch this setting",
# you might still have one of the options set from the kernel commandline.
# Be careful, this might crash your machine.
SUSPEND2RAM_ACPI_SLEEP="3"


Hope someone can help me, cause i'm just lost here... It should work in my head

Here's the s2ram -i output

sys_vendor = "Acer "
sys_product = "TravelMate 230 "
sys_version = "-1 "
bios_version = "R01-A1D "

Hope you can help me on this...

Jakob
 
Old 11-04-2007, 04:47 AM   #2
jakob_g
LQ Newbie
 
Registered: Sep 2004
Location: Denmark
Distribution: openSuse 10.3
Posts: 26

Original Poster
Rep: Reputation: 15
bump
______
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Preventing Brute Force Attacks With Fail2ban On OpenSUSE 10.3 LXer Syndicated Linux News 0 10-15-2007 03:50 PM
s2ram-- VT blank upon resume mattd7591 Linux - General 2 06-29-2007 10:52 AM
OpenSuse 10 wont start, i think its firewall santamaycry Suse/Novell 4 01-11-2006 06:03 AM
OpenSUSE soundblaster Live! wont alsactrl store cselph Linux - Hardware 2 12-28-2005 05:50 PM
'force user' options does not work? Cps530 Linux - Security 2 10-04-2002 06:16 AM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration