LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2004, 03:51 PM   #1
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Rep: Reputation: 50
Running X as local user


Hi,

I am trying to run X as a local user. This does not work and I have to be root to run the command "startx". This is the error:

Code:
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov  5 22:47:28 2004
(==) Using config file: "/etc/X11/xorg.conf"

Fatal server error:
xf86OpenConsole: Server must be suid root


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
/MezzyMeat
 
Old 11-05-2004, 04:07 PM   #2
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 31
Check the permissions on /usr/X11R6/bin/Xorg, mine is

Code:
-rws--x--x    1 root     root      2088119 Oct 12 20:09 /usr/X11R6/bin/Xorg
You probably dont have suid bit set, to set like the above example run as root -

chmod 4711 /usr/X11R6/bin/Xorg

HTH

Mad
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup local machine to allow lan machines to retrieve its local user mail. Brian1 Linux - Networking 3 03-30-2006 05:04 AM
rc.local not running? sbirnie Slackware 6 04-13-2005 01:18 AM
Unable to login as local user with vsftpd running on the server kairamr Linux - Newbie 1 06-09-2004 02:25 PM
rc.local not running at boot anthjaz Fedora 7 05-12-2004 01:40 PM
rc.local not running on boot??? Evilone Linux - Software 1 09-08-2003 01:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration