LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-11-2004, 03:54 PM   #1
sp406
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Rep: Reputation: 0
Running in modulated clock mode... by mistake?


Here's the question guys:

I am running Suse 9.2 (Pentium IV 3GHz + HT, 1Gb ram, nVidia 6800) and I can't seem to get to the root of this problem.
I keep getting the following console messages as soon as the cpu load is above regular web browsing load:

Message from syslogd@linux at Sat Dec 11 20:41:35 2004 ...
linux kernel: CPU0: Temperature above threshold

Message from syslogd@linux at Sat Dec 11 20:41:35 2004 ...
linux kernel: CPU1: Temperature above threshold

Message from syslogd@linux at Sat Dec 11 20:41:35 2004 ...
linux kernel: CPU1: Running in modulated clock mode

Message from syslogd@linux at Sat Dec 11 20:41:35 2004 ...
linux kernel: CPU0: Running in modulated clock mode

The video card is running at good temperature, while I am pretty sure the cpu temperature is fine as well (bios temp is fine and cpu fan is modulated to rev up when temp goes up, but the fan never goes at higher revs).
If run the cpu fan at constant high speed the messages show up regardless... Also when I run windows and even play doom3, cpu temp is still nice and cool... I think I can exclude the cpu being hot!
If I query sensors, first I get:

Can't access procfs/sysfs file
Unable to find i2c bus information;
For 2.6 kernels, make sure you have mounted sysfs and done
'modprobe i2c_sensor'!
For older kernels, make sure you have done 'modprobe i2c-proc'!

When I do modprobe i2c_sensor and then sensors again I get:

No sensors found!

I tried looking on the web for this, but for what I could see the origin of this problem generally was that the cpu temp was really above normal, but I really don't think that's my case... What's the deal? How can I fix this? Any ideas?

Thanks a bunch,
Simone
 
Old 12-11-2004, 11:54 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
hi,
this is a hard one !
the fact that it starts up after putting some load implies it's working doesn't it (anybody)?
wouldn't want to turn it off if it's needed.
i wonder what triggers these mesages is apmd or acpid running ?
i'l try to get you started but i don't use this so i can't really follow up
forgive 20 questions
hopefully others will step in
this is some kindof acpi thermal_zone thing trying to regulate cpu speed to keep temp down
is this a laptop ?
if it's a laptop you can try
as a boot parameter acpi=on and see if it helps
or to try to make this go away (especially if it's not a laptop) you could try booting with
pci=noacpi or acpi=off

show us
dmesg | grep apm
and
dmesg | grep acpi

it's weird cause it's a kernel message which means either a loaded module or something compiled in
try showing us
lsmod | grep i2c

just to follow the message
do you have in your /etc/fstab
none /sys sysfs defaults 0 0
and a directory /sys ?

is there a file /etc/cpuspeed.conf ? and what does it say ?
what says /etc/rc.d/init.d/cpuspeed status ?
whats in /proc/acpi/thermal_zone ?

what's in /etc/acpi/events ?

if you want to try to get it working
in order to setup lm_sensors you do as root
sensors-detect
and follow along it tells you what to put in modprobe.conf and gives you an init script



this is another thread i found about this
http://www.linuxquestions.org/questi...hreadid=255402

Last edited by foo_bar_foo; 12-12-2004 at 12:01 AM.
 
Old 12-12-2004, 01:10 PM   #3
sp406
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks so much for the ideas, I'll give it a try!
I tried turning off and on each individual power management scheme in BIOS and also to turn off hardware monitoring, but I still got those messages. And, no, it's not a laptop... I tried sensors-detect before but it couldn't find any...
Simone
 
Old 12-19-2004, 06:00 AM   #4
voltumna
LQ Newbie
 
Registered: Jun 2004
Posts: 4

Rep: Reputation: 0
I have exactly the same problem, I thought it was something of a hardware issue, so I fiddled around with the connetions but the problem persistend, and the blipping really kills me (I unplugged the blipping connection of my computer for that... ), this did not work so I had an idea, I put win2K on and when I load win2K, there is no blipping or errors on the temperature, all is status quo.I cannot always have the tty0 to 6 flooded with messages of CPU temperatures, and the system thinks the computer is a laptop, is there any way to resolve this?

Ciao,

Maurizio
 
Old 12-28-2004, 12:48 PM   #5
jjean
LQ Newbie
 
Registered: Dec 2004
Posts: 3

Rep: Reputation: 0
Hi

I have exactely the same problem
i have an inspiron xps laptop P4 3.4Ghz HT
the idle temp is 62C
when i run some calculations >> it goes up to 76C
and at this point i have this famous message showing up
>>> Running in modulated clock mode
i did the same than you

trying lm_sensors etc ...

it doesn t find any PCI ias etc ... chip

I m using mandrake 10.1
acpi is running

under windows
the temp in idle is the same about 55C

at this point i don t know what to do

changing fan heat sink
changing distribution

or getting help ... ??

help would be a lot appreciated

so thanks

jean
 
Old 07-14-2006, 12:18 PM   #6
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Rep: Reputation: 15
wow! is this old?

this thread is older than the hills, but i have the same problem on mandrive one, dell dimension 2300.

don't get any signs of over heating or anything under windows xp.

anybody ever figure out anything?

thanks
 
Old 12-03-2006, 06:20 PM   #7
bohdie
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Rep: Reputation: 0
acpid - partial success

Not that this is the solution, but for now, I went to the cmd line, went typed setup. Went to services and unselected acpid. For now it appears to be gone.

What I really hated, was that the warnings would come up in the middle to typing.

So this cleared the temp warnings, but I still receive the Running in modulated clock mode.
 
Old 08-29-2007, 09:35 AM   #8
baddah
Member
 
Registered: Feb 2006
Location: Cape Town,South Africa
Distribution: Fedora Core 8
Posts: 185

Rep: Reputation: 30
Hi,

Very old thread i know,maybe someone replies...

I get the same error mentioned above running FC4.I have cleaned my CPU and so on,there was a bit of dust,but its clean now,and the message keeps popping up.The CPU temp seems fine(at around 58 degrees Celcius it might be a bit high for a Intel Pentium CPU,but no bad,am i right?).Does anybody know what can cause this?

Quote:
pci=noacpi or acpi=off
Will this really help.Are you then just not hiding the issue as opposed to fixing it?
 
Old 01-30-2008, 04:51 PM   #9
DanH51
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Bump

I'm having this problem running FC5 on an XPS laptop. Its warm, but I don't think it is actually overheating. It is fine in Windows.

Any thoughts? It hits pretty hard, slows down scrolling through an editor to where it appears to be page scrolling.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP clock (text mode) swmok Programming 2 05-03-2005 06:57 PM
Running a program automatically by the clock? orange400 Linux - General 4 07-12-2004 06:38 AM
Kernel 2.6.x running in modulated clock mode wesmont Linux - Hardware 10 05-27-2004 10:41 PM
CPU#0:Runing in modulated clock mode shams Mandriva 2 05-26-2004 06:12 PM
The clock is running too fast satimis Linux - Hardware 4 03-19-2004 10:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration