Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-25-2004, 09:51 AM   #1
LQ Guru
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58

hi there
i am facing some problem here
i have added
xhost +mymachineip

in .bash_profile

when i login into kde
it does get executed but when i go to icewm it does not
pl. help
Old 04-25-2004, 04:39 PM   #2
Registered: Apr 2004
Location: TN
Distribution: Only used RH but have heard good things about Mandrake. BSD might be interesting.
Posts: 46

Rep: Reputation: 15
.profile runs only at login. if you need something to run whenever a new bash shell is ceated, put it in .bashrc in your home dir. if you are not actually loggin in the icewm, .profile wouldn't be run again. you also might check to see if icewm has an rc file associated with it. if it does, that might be the best place to put your xhost + stuff.
Old 04-27-2004, 08:17 AM   #3
LQ Guru
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Original Poster
Rep: Reputation: 58
i do not have .bashrc file.

what do u suggest????
Old 04-27-2004, 09:00 AM   #4
Registered: Jan 2002
Location: Missoula. Montana, USA
Distribution: Slackware (various)
Posts: 457

Rep: Reputation: 41
$ cp /etc/bashrc $HOME/.bashrc
$ vi $HOME/.bashrc
Old 05-02-2004, 10:41 AM   #5
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Rep: Reputation: 30
I have a Microsoft Internet Keyboard with a few extra keys.
I run lineakd to enable these keys.
Now I would like to add a line into bashrc or bash_profile so that this command runs on boot. I don't know how to add it.
I tried simply adding the command "lineakd", but in this case only the lineakd will start, not the KDE. Sorry, I am not talking about the same problem, but the solution should be the same.
Please, help. The command should only run if lineakd isn't already running.

Last edited by linuxfond; 05-02-2004 at 10:42 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu How to run Python script on Login? warnetgm Linux - General 14 03-13-2012 07:11 PM
How to run a script as root upon login zugvogel Linux - Newbie 7 09-09-2005 12:10 PM
How to run a Script as root, after Login as User, in GDM MHOOO Red Hat 14 03-08-2005 09:41 AM
Run script at login instead of bash uzi4u Linux - General 2 04-28-2004 03:31 PM
run a script once at login? shanenin Linux - Software 2 04-25-2004 11:32 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:11 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration