LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-27-2010, 09:52 AM   #1
paidbythehour
LQ Newbie
 
Registered: Jan 2009
Posts: 20

Rep: Reputation: 0
RTSP problem with Darwin Streaming Server


Hi there,

I am running Darwin Steaming Server (6.0.3-2) on CentOS 5.4, and I'm having a problem with RTSP requests only being answered on one network interface. For example:

eth0: 123.123.123.123 (public net)
eth1: 10.10.10.10 (local net)

Darwin is up and running on system A. I am using system B to test Darwin, by accessing it's administration page (port 1220). I can get to the administration page by using either the eth0 or eth1 IP addresses. So far so good.

But when I access a test file (sample.mp3) via RTSP, I can only get the stream if I use the IP associated with the eth0 address. If I try and access the file using the eth1 address, Quicktime gives me an error saying "-3285 Dissconnected"

Does anyone know what I'm missing here? In my config file, I was able to confirm that RTSP is answering requests on port 554, but I didn't see anything that would restrict it to a single network interface.

Here's a summary of the above:

http://123.123.123.123:1220 (works)
http://10.10.10.10:1220 (works)
rtsp://123.123.123.123/sample.mp3 (works)
rtsp://10.10.10.10/sample.mp3 (Does not work!)

Thanks in advance.
 
Old 04-28-2010, 04:09 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 250Reputation: 250Reputation: 250
Does this help ?
http://patrickgibson.com/news/andsuch/000113.php

Also check your firewall is open to 554 on eth1
 
1 members found this post helpful.
Old 04-28-2010, 08:29 AM   #3
paidbythehour
LQ Newbie
 
Registered: Jan 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for the link smoker, I finally got this working.

For reference, here is configuration option in streamingserver.xml:

<PREF NAME="bind_ip_addr" >0</PREF>

The value 0 means the streaming server should bind to all IP's on the server, which wasn't happening for me. So I replaced the value with the IP I want:

<PREF NAME="bind_ip_addr" >10.10.10.10</PREF>

And it worked! I'm not sure why the default value wouldn't work (not running a firewall) but this is good enough for me.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to play RTSP streaming from YouTube server paldebojyoti Programming 0 03-06-2010 01:34 AM
Darwin streaming server Video streaming local only ahmed_as8 Linux - Networking 2 05-28-2009 02:52 PM
Q for Darwin Streaming Server ahmed_as8 Linux - Software 0 05-08-2009 02:11 PM
Darwin Streaming Server problem tendonut Linux - Software 0 11-11-2005 12:37 PM
Darwin Streaming Server Connection problem mting923 Linux - Newbie 0 11-09-2005 12:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration