LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   rtcwake doesn't wake PC up (https://www.linuxquestions.org/questions/linux-software-2/rtcwake-doesnt-wake-pc-up-4175622080/)

Teufel 01-21-2018 04:18 AM

rtcwake doesn't wake PC up
 
Hi there,
trying to wake my desktop up automatically after a specified timeout, but can't get it.

Code:

rtcwake -m mem -s 20
puts PC in a sleep mode but doesn't wake it up, though I can wake it up manually by pressing any key at the keyboard.

At the BIOS suspend mode is set to S3 and "Wake by RTC" option set to enabled.

Am I missed something? Probable some kernel option should be enabled?

Teufel 01-21-2018 05:45 AM

Here is the dmesg output (from the time I put a system to suspend to the moment when I woke the PC up by keyboard 30 secs later):

Code:

[ 4961.891497] Freezing user space processes ... (elapsed 0.001 seconds) done.
[ 4961.892837] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 4961.894013] Suspending console(s) (use no_console_suspend to debug)
[ 4961.894329] i8042 kbd 00:02: System wakeup enabled by ACPI
[ 4961.894786] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[ 4961.894803] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 4961.894846] sd 1:0:0:0: [sdb] Stopping disk
[ 4961.894879] sd 0:0:0:0: [sda] Stopping disk
[ 4962.307008] PM: suspend of devices complete after 412.896 msecs
[ 4962.307234] PM: late suspend of devices complete after 0.223 msecs
[ 4962.307528] pcieport 0000:00:1c.3: System wakeup enabled by ACPI
[ 4962.307573] pcieport 0000:00:1c.1: System wakeup enabled by ACPI
[ 4962.307721] ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
[ 4962.307904] ehci-pci 0000:00:1a.0: System wakeup enabled by ACPI
[ 4962.319086] PM: noirq suspend of devices complete after 11.850 msecs
[ 4962.319247] ACPI: Preparing to enter system sleep state S3
[ 4963.331478] PM: Saving platform NVS memory
[ 4963.331695] Disabling non-boot CPUs ...
[ 4963.332936] smpboot: CPU 1 is now offline
[ 4963.339767] smpboot: CPU 2 is now offline
[ 4963.347532] smpboot: CPU 3 is now offline
[ 4963.356051] ACPI: Low-level resume complete
[ 4963.356096] PM: Restoring platform NVS memory
[ 4963.356453] Suspended for 29.923 seconds
[ 4963.356924] Enabling non-boot CPUs ...
[ 4963.359215] x86: Booting SMP configuration:
[ 4963.359216] smpboot: Booting Node 0 Processor 1 APIC 0x2
[ 4963.361754]  cache: parent cpu1 should not be sleeping
[ 4963.361859] CPU1 is up
[ 4963.364228] smpboot: Booting Node 0 Processor 2 APIC 0x1
[ 4963.366637]  cache: parent cpu2 should not be sleeping
[ 4963.366758] CPU2 is up
[ 4963.375257] smpboot: Booting Node 0 Processor 3 APIC 0x3
[ 4963.377648]  cache: parent cpu3 should not be sleeping
[ 4963.377798] CPU3 is up
[ 4963.379934] ACPI: Waking up from system sleep state S3
[ 4963.392238] pcieport 0000:00:1c.3: System wakeup disabled by ACPI
[ 4963.392325] ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
[ 4963.392530] ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
[ 4963.392582] PM: noirq resume of devices complete after 12.159 msecs
[ 4963.392718] PM: early resume of devices complete after 0.109 msecs
[ 4963.392867] pcieport 0000:00:1c.1: System wakeup disabled by ACPI
[ 4963.397128] usb usb3: root hub lost power or was reset
[ 4963.397129] usb usb4: root hub lost power or was reset
[ 4963.401064] i8042 kbd 00:02: System wakeup disabled by ACPI
[ 4963.401067] rtc_cmos 00:04: System wakeup disabled by ACPI
[ 4963.401470] sd 0:0:0:0: [sda] Starting disk
[ 4963.401506] sd 1:0:0:0: [sdb] Starting disk
[ 4963.503349] hpet1: lost 5 rtc interrupts
[ 4963.507673] r8169 0000:03:00.0 eth0: link down
[ 4963.713401] ata5: SATA link down (SStatus 0 SControl 300)
[ 4963.820272] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
[ 4963.880111] usb 1-1.5: reset low-speed USB device number 3 using ehci-pci
[ 4964.154194] PM: resume of devices complete after 761.442 msecs
[ 4964.154308] Restarting tasks ... done.
[ 4967.093248] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 4967.128739] ata2.00: configured for UDMA/133
[ 4967.197250] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 4967.350827] ata1.00: configured for UDMA/133
[ 4968.315056] r8169 0000:03:00.0 eth0: link up

When the system is going to sleep
Quote:

System wakeup enabled by ACPI
But when its a time to wake up
Quote:

System wakeup disabled by ACPI
Any idea?


All times are GMT -5. The time now is 08:30 AM.