-   Linux - Software (
-   -   rsync via reverse ssh tunnel (

dexznrl 02-07-2011 03:44 PM

rsync via reverse ssh tunnel

I run a cygwin installation on my windows 7 laptop.

I run a rsync service, it works perfectly and is up and running.

I start a reverse ssh tunnel: ssh -R 877:localhost:873
The tunnel works and is up and running.

Then from my server I run the following command
rsync -av --port 877 useronlap@localhost::modulename/c/Users/useronlap/Documents/ /root

Everything works except for ,,,,, in the filenames.

If I on the other hand runs rsync via ssh from my laptop to my server directly the swedisch characters works.

Both the server and the laptop cygwin installation runs on sv_SE.ISO8859-1.

Anybody out there with a solution?

Best regards


misconfiguration 02-08-2011 08:38 AM


I'm just throwing idea's out here so please don't flog me if it's not a good solution for you.

Have you tried adding a process to your script, such as some commands to tar your files before they're sent in rsync? If you're using rsync to update flat files rather frequently this idea may be useless.

All times are GMT -5. The time now is 08:18 PM.