-   Linux - Software (
-   -   Rsync Errors during backups (

shawnbishop 05-04-2006 11:34 PM

Rsync Errors during backups
Good Day

I get the following errors when I do a rsunc between my Server and a 200GB USB drive

rsync error: error in rsync protocol data stream code (code 12) at io.c (359)
rsync error: mkdir "/media/usbdisk4/SiteA" failed: no space on device (28)

I have checked the space on the device and I am only using 80GB of a 200GB drive so there is space on the device.


Shawn Bishop

bulliver 05-05-2006 07:42 PM

Are there large numbers of small files? You may be out of inodes.
Are there user-quotas in effect?
"/media/usbdisk4": This is the 200GB drive?

shawnbishop 05-07-2006 12:54 PM


Well it is an architect firm with a large amount of files,on average about 2 to 5 MB a file.

Yes the /media/usbdisk4 is the 200GB usb dirve

There are no user-quotas in effect.

I have updated the rsync to 2.6.8 and still get the same errors


JZL240I-U 05-09-2006 02:10 AM

What type of file system do you use? Did you run fsck and what did it tell you? Is the drive maybe partiotioned? What says fdisk?

shawnbishop 05-18-2006 03:26 AM

Good Day

Sorry took so long to answer, I think I have solved the problem.When the drives were plugged into the Server they were being automounted as ext2, I changed this to xfs and formatted the drives.

The Backups now run as full backups and I get about 160GB of data.

Thanks for your time, you at least put me on the right path.


All times are GMT -5. The time now is 03:33 PM.