LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   rsync: error while copying (https://www.linuxquestions.org/questions/linux-software-2/rsync-error-while-copying-461808/)

Fusi 07-07-2006 10:50 AM

rsync: error while copying
 
hey guys!

I would like to backup my system with rsync. Befrore writing a complete script I wanted to understand how rsync works and if everything works all right.
I tried to backup my home dir to my external hdd. Therefore I used this command:

Code:

rsync -avz --del --force --progress --exclude-from=/home/fixje/backup-script/exceptions /home/fixje/ /mnt/exhdd/linux_fixje/home
As result many files where copied correctly and even the exceptions worked!
But then I got an error

Code:

building file list ...
507 files to consider
./
?
          6 100%    0.00kB/s    0:00:00  (1, 0.4% of 507)
.fonts.cache-1
          41 100%  20.02kB/s    0:00:00  (2, 1.4% of 507)
rsync: mkstemp "/mnt/exhdd/linux_fixje/home/.?.Zrtftp" failed: Invalid argument(22)

sent 10565 bytes  received 70 bytes  21270.00 bytes/sec
total size is 192509874  speedup is 18101.54
rsync error: some files could not be transferred (code 23) at main.c(789)

I have really no idea!
Thanks for your replies!!

MensaWater 07-07-2006 11:02 AM

You have a file named "/mnt/exhdd/linux_fixje/home/.?.Zrtftp"?

The ? is a shell meta-character that matches any single character. It may be that rsync thinks you are looking for files like:
.a.Zrtftp, .b.Zrtftp etc... but you don't have anything. I'd really suggest you not name files with special characters in them like this.

Fusi 07-07-2006 11:06 AM

that's the joke:
there is no such file containing a '?' or a file that's named like '.?.Zrtftp'

What I forgot to mention: the filename always changes with every attempt!

MensaWater 07-07-2006 11:18 AM

If you go to /mnt/exhdd/linux_fixje/home and do "ls -la" what IS there? It may be that trying to list the file is having odd issues because it encounters the meta-character.

Is the file always in the same path?

Does the file always appear to have the ? in its name?

Fusi 07-07-2006 11:34 AM

if I do a "ls" I don't see any file looking like this. But what I found is (as you can see in the error message) that these files are only temporary files which always look the same way:
.?.<random combination of chars>

Mountain 06-10-2013 12:00 AM

Is it OK to revive this question? I have the exact same problem now with Kubuntu 12.04. It is explained so well here already, why make a new question? Furthermore, this thread is showing up near the top in google, but it doesn't have an answer. So I propose to reuse the thread and hopefully get an answer this time. Thanks


All times are GMT -5. The time now is 01:16 PM.