LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-11-2013, 04:40 AM   #1
genderbender
Member
 
Registered: Jan 2005
Location: US
Distribution: Centos, Ubuntu, Solaris, Redhat
Posts: 396

Rep: Reputation: 31
rsync'd db and now rpm -qa doesn't work


Hi guys, I've been rsyncing data from one server to another and this has proven successful except in the case of rpm, where rpm -qa gives the following error
Quote:
D: opening db environment /var/lib/rpm/Packages joinenv
D: opening db index /var/lib/rpm/Packages rdonly mode=0x0
D: locked db index /var/lib/rpm/Packages
D: closed db index /var/lib/rpm/Packages
D: closed db environment /var/lib/rpm/Packages
D: May free Score board((nil))
I've tried rebuilding the database with no success and booting the server int single user mode and running rpm --initdb with no success, anyone able to help? I've also removed the /var/lib/__db blah files prior to running these commands.
 
Old 09-11-2013, 08:01 AM   #2
eklavya
Member
 
Registered: Mar 2013
Posts: 633

Rep: Reputation: 141Reputation: 141
This document shows the rpm database recovery.
http://www.rpm.org/wiki/Docs/RpmRecovery
 
Old 09-11-2013, 08:28 AM   #3
genderbender
Member
 
Registered: Jan 2005
Location: US
Distribution: Centos, Ubuntu, Solaris, Redhat
Posts: 396

Original Poster
Rep: Reputation: 31
Looks like it's a bug then as I followed these instructions... That's unfortunate Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rpm doesn't work when used with URL that's redirected veeruk101 Linux - Newbie 2 06-05-2011 06:08 AM
cronjob rsync doesn't work vielmaj Linux - Server 6 03-28-2011 12:41 PM
rpm -i --prefix=/home/user package.src.rpm doesn't work? registering Linux - Software 2 07-18-2007 11:28 AM
rpm -e doesn't work for me! Freestone Linux - Newbie 5 03-31-2006 07:43 PM
¿Why RPM installs doesn't work on my red hat 9 linux system? Corlinux Linux - Software 8 04-05-2004 06:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration