Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-19-2003, 12:22 PM   #1
LQ Newbie
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
RPM - stupid problem with

Hi all!
My problem is very simple but stupid
I tried to upgrade RPM but there was rpmlib(PartialHardLinkSets) dependency that i cannot find a solution for. I decided to install newest rpm version with --nodeps flag. And here is my problem - this rpm version (4.2-1) needs library from glibc 2.2.3 version. But i have glibc version 2.2.93-5 installed. I can't install never version because of the error with library:

rpm: /lib/ version `GLIBC_2.3.2' not found (required by /usr/lib/

i can't compile glibc 2.3.2 because i don't have gcc installed :/

what shall i do?
i cannot install any new software because of rpm error and no gcc compiler installed

please help me!
thanx a lot
Old 06-19-2003, 02:04 PM   #2
Senior Member
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
That's why you shouldn't have forced the install of your installer.
Try forcing rpm's removal, then upgrade to the version of gcc which rpm depends on, and then install once you've satisfied the dependencies next time.
Old 09-04-2003, 01:57 PM   #3
Registered: Mar 2003
Location: Cambridge, MA, USA
Distribution: Ubuntu (Dapper and Heron)
Posts: 377

Rep: Reputation: 31
Ok Proud,

so I avoid forcing rpm. But what is rpmlib(PartialHardlinkSets)? Unlike other packages, rpm -q won't tell me about it. And how do I get it?

rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by all of
gcc-3.3-14, glibc-common-2.3.2-57, gcc-3.2-7
Old 09-06-2003, 04:57 PM   #4
Registered: Mar 2003
Location: Cambridge, MA, USA
Distribution: Ubuntu (Dapper and Heron)
Posts: 377

Rep: Reputation: 31

rpmlib(PartialHardlinkSets) means rpm. And the "<=" is misleading; rpm 4.0.3 won't do. What the line is saying is, you have to get rpm 4.0.4. I don't know if "at least" or "exactly", but it's NOT "at most" as the line states.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post RPM downlaod executive Linux - Software 2 03-23-2005 04:59 PM
rpm needs (glibc_2.3.4) sirius57 Linux - Software 8 11-28-2004 05:32 PM
Which RPM contains etae Linux - Software 1 09-09-2003 06:09 AM
Stupid choice using RPM mrsolo Linux - Software 4 05-05-2003 08:26 PM problem ih8linux Linux - Software 11 04-21-2003 03:08 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration