LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   rpm -q claims "installed" but rpm -ivh claims "already installed" (https://www.linuxquestions.org/questions/linux-software-2/rpm-q-claims-installed-but-rpm-ivh-claims-already-installed-138934/)

topgunjones 01-26-2004 03:28 PM

rpm -q claims "installed" but rpm -ivh claims "already installed"
 
Hey,
I have a problem while trying to install oracle 9i I discovered that I needed to check
to see if certain packages were installed. glibc-kernheaders-2.4-7.20.i386 wasn't installed
according to the following

[root@xxy topgun]# rpm -q glibc-kernheaders-2.4-7.20.i386.rpm
package glibc-kernheaders-2.4-7.20.i386.rpm is not installed


As you can see below, I attempted to install the rpm.

[root@xxy topgun]# rpm -ivh glibc-kernheaders-2.4-7.20.i386.rpm
warning: glibc-kernheaders-2.4-7.20.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing... ########################################### [100%]
package glibc-kernheaders-2.4-7.20 is already installed


As a test to see if it was installed, I tried to uninstall it.

[root@xxy topgun]# rpm -e glibc-kernheaders-2.4-7.20.i386.rpm
error: package glibc-kernheaders-2.4-7.20.i386.rpm is not installed


Can't continue without solving this one.

Thanks in advance.

TopGun

acid_kewpie 01-26-2004 03:37 PM

do this
rpm -q glibc-kernheaders-2.4-7.20

because "glibc-kernheaders-2.4-7.20" is the PACKAGE name, but "glibc-kernheaders-2.4-7.20.i386.rpm" is the FILE name. Maybe seem a little confusing, but in windows you don't go into control panel to uninstall "setup.exe" do you?

Allen614 01-28-2004 09:01 PM

If that doesn't work do "rpm --rebuilddb" and then try again. Yoy may have corrupted the db. It used to be quite common.

Redbone981sl 01-29-2004 08:31 PM

Don't put the version in just type rpm -q glibc-kernheaders.


All times are GMT -5. The time now is 06:55 AM.