LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   RPM package installation problems (https://www.linuxquestions.org/questions/linux-software-2/rpm-package-installation-problems-72653/)

nanabaffoe 07-14-2003 02:44 PM

RPM package installation problems
 
HI,

I am very new to the world of the Linux operating systems, I am using Mandrake 9.1, KDE 3.1,on a dell optiplex gx110, when installing RPM packages on my Linux box, for some reason they always come up with bad signitures and conflicts that cause installation to be aborted.
Anything I am not doing right or don't know about?
Your help would be greatly appreaciated. Also what advice would you give me, a very very very new person to the linux world, on how to get resources that make learning and eventually using linux somewhat simpler..

Thanks
Nanabaffoe:
newbie:
:(

DrOzz 07-14-2003 02:51 PM

type rpm -ivh packname.rpm in the terminal and just show us some of the error outputs your getting, and also as to learning, there are hundreds of places on the net to find help, for example this website as its the whole point....do a search for something your curious about on this site and i am sure you'll get results, and even if you want to use google....a good way to use it is to go to www.google.ca/linux as all the search results will be linux related and you really don't have to worry about filtering through the results like you may have to if you search for something on www.google.ca ....even just look at peoples sigs on this board you'll find some pretty helpful sites...i have a couple below my name, and alot of the moderators along with many others have some pretty good links too :D

nanabaffoe 07-14-2003 03:55 PM

RPM packages again
 
when i try to install libfam-devel..
i get the ff error msg.
[root@localhost Desktop]# rpm -ivh libfam-2.6.9-alt1.i586.rpm
Preparing... ########################################### [100%]
file /usr/lib/libfam.so.0.0.0 from install of libfam-2.6.9-alt1 conflicts with file from package libfam0-2.6.9-5mdk
[root@localhost Desktop]# rpm -ivh libfam-devel-2.6.9-alt1.i586.rpm
error: failed dependencies:
libfam = 2.6.9-alt1 is needed by libfam-devel-2.6.9-alt1

Then when i try to install libfam-2.6-9... it says file is in conflict with libfam0

HELP!!!!!!!
:newbie: :confused:

DrOzz 07-14-2003 04:15 PM

well as you will see in the first error message it is saying there is in fact a conflict, but if you analyze it closer, its conflicting because its the same package, well its a different version, but in other words, you have it installed...if you do for some reason want to continue with the installation, your going to have to remove the previous version, that is if something you are trying to install requires the one you want to install...otherwise, the point of all this is, is that you already have that installed.

and the reason the devel package fails is because you don't have the first package installed which is the one conflicting..so when you get the first package installed, then that specific devel package will then install.
you may already have the devel package installed for you existing version, so if it is unneccesary to install the one you are trying to then there is no need for either package...
issue the command:
rpm -qa|grep -i libfam, and you will see what libfam packages are installed..

emetib 07-14-2003 06:14 PM

this is what i would do, not that drozz isn't doing a great job.

go here and search for urpmi.setup. get the mandrake 9.x one.

then-
rpm -ivh urpmi.setup-0.4.4-4mdk.noarch.rpm
(you shouldn't get any errors on that.)

su
passwd
urpmi.setup

once the gui comes up, go through and select your contribs, main, and updates. then you will want to validate them, click ok.
this will take a bit to do, i wouldn't do more then three, hopefully your on a highspeed connection.

once that is done-
urpmi -y libfam
(if you get any errors about no urpmi, then go to the site above and get that also.)

you should see a selection of libfams for you. type in the one that you want.

urpmi libfam....

that will give you the mandrake libfams that are out. the nice thing about urpmi is that it will take care of your deps for you. once you have your libfams then-

urpmi.update -a (you can put --wget here if you would like, i do.)
once that is done-
urpmi --auto-select (--wget)

this will update all of your packages to what is the current.

that's just a little bit longer and more involved then what drozz is telling you, but when you get that done, you can just go to the cmd line and ask for packages that you would like to install without having to search for them and get errors like what you have received now.

cheers.

nanabaffoe 07-16-2003 11:37 AM

thanks
 
thanks DrOzz and emetib, I used rpm -ivh and it worked, i also used the urpmi.setup and it worked To!!!.
Now the initial issue of using Kmess is solved.
thanks again
cheers.
:newbie: :D

emetib 07-16-2003 06:26 PM

your welcome.

cheers.

browny_amiga 07-18-2003 08:06 AM

there is apt-get (apt get rpm)
 
If case you ever have problems again with dependencies and such:

Try apt-get for RPM... I live carefree with rpm since I got that tool. It get's the stuff that it needs all by itself.

Well, your problem is solved. Just wanted to point out another possibility, incase you get problems in the future.


All times are GMT -5. The time now is 01:46 AM.