LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   rpm install: A asks for B, B asks for A (https://www.linuxquestions.org/questions/linux-software-2/rpm-install-a-asks-for-b-b-asks-for-a-343351/)

mike_bio 07-15-2005 03:30 AM

rpm install: A asks for B, B asks for A
 
I'm new to linux (RH9) and came across the following problem. While compiling php5, I got "libxml2 version 2.5.10 or greater required". I currently have libxml2-2.5.4-1. I downloaded libxml2-2.5.11-0.fdr.2.rh90.i386.rpm. The problem is that when I try to install it (with rpm -i or -U or -F) I get
error: Failed dependencies:
libxml2 = 2.5.4 is needed by (installed) libxml2-python-2.5.4-1
libxml2 = 2.5.4 is needed by (installed) libxml2-devel-2.5.4-1

BUT when I try to install (the same way) libxml2-python-2.5.11-0.fdr.2.rh90.i386.rpm i get "libxml2 = 2.5.11 is needed by libxml2-python-2.5.11-0.fdr.2.rh90" and when I try to install libxml2-devel-2.5.11-0.fdr.2.rh90.i386.rpm I get "libxml2 = 2.5.11 is needed by libxml2-devel-2.5.11-0.fdr.2.rh90".

So, I have a full circle. I suspect the solution to be something very simple, but this is a newbie talking!

Neverendingo 07-15-2005 03:44 AM

Did you try "rpm -Uvh libxml2*.rpm" ?
On my opinion it checks all the dependencies and installs it in the right order.

Greetings,
Ingo

or1onas 07-15-2005 04:16 AM

Try first to remove libxml2-python-2.5.4-1 and libxml2-devel-2.5.4-1 and then proceed with the installations of the newer version.

mike_bio 07-15-2005 04:41 AM

"rpm -Uvh libxml2*.rpm" gives me 6 messages saying "xxxx conflicts between attempted installs of libxml2-2.5.11-0.fdr.2.rh90 and libxml2-2.5.4-3.rh9" and exits.

I cannot just remove (-e) the old packages because others depend on them ("libxml2-python is needed by (installed) redhat-config-packages-1.1.8-1")

or1onas 07-15-2005 04:46 AM

Have you tried to upgrade libxml2-python first?

mike_bio 07-15-2005 04:58 AM

a friend of mine suggested "rpm -Uvh --force --nodeps". It worked! Thank you for your help.

or1onas 07-15-2005 05:00 AM

That was the next step i was about to propose, but it might be dangerous (ie.it might corrupt other installed packages which need a specific version).
But if it works ok, that's good!


All times are GMT -5. The time now is 01:19 PM.