LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   RPM dependancy problem (https://www.linuxquestions.org/questions/linux-software-2/rpm-dependancy-problem-4622/)

glj 07-23-2001 11:40 AM

RPM dependancy problem
 
I'm trying to install a GCC RPM in Redhat 7.1. Another RPM
CPP-something is dependant on the GCC compiler and won't let me continue. I've also downloaded the cpp RPM and tried to install them both using a wildcard, and letting rpm sort out the order to install them, but that doesn't work either.

Is there a way to install it without forcing it? If not, will there be any side effects of forcing it? Should I get rid of the offending RPMs and install the new ones?

Cheers

glj

isajera 07-23-2001 05:45 PM

i wasn't even aware that the gcc package came in rpms. i thought they only distributed it as tarballs. are you trying to install the gcc 3.0?

glj 07-24-2001 03:29 AM

I'm trying to install 2.96-85 (got it from rpmfind.net, along ith cpp-2.96-85). Red Hat 7.1 ships with 2.96.81, which I was told is a mistake as it is a development version and isn't even listed on the gcc site. The reason I need to upgrade gcc is because of MySQL. I was using Apache Tool Box and it would always bomb out when compiling MySQL (I cant compile MySQL by itself either). The ATB web site says you should upgrade your MySQL version to xx-38 to fix that, but I was running that anyway (I've also tried xx-40). I thought that maybe it was the c compiler that was the problem, so I'm trying to get that to a reasonable version.

Help!

glj

cinnix 07-24-2001 04:03 AM

I had a similiar problem before trying to update gcc in redhat 7.0. If you use the --nodeps option when using rpm, it will get you past this problem. I know that this is the sloppy way to do things but after unsuccessfully asking the question here and at redhat, I was not able to find an acceptable answer.

This is my previous post regarding the same (or similiar) problem.

http://www.linuxquestions.org/questi...&highlight=gcc

One thing that you want to make sure of is that you have all of the necessary packages before using the --nodep option.

glj 07-24-2001 04:34 AM

Got it!

Went here: -

http://www.redhat.com/support/errata/RHBA-2001-082.html

downloaded all the packages and they installed fine.

Now to install MySQL........

Cheers

glj

cinnix 07-24-2001 04:59 AM

good to here, a lot of people have had problems updating these packages in redhat 7.0. I am happy to see that this problem may not exist in 7.1.

glj 07-24-2001 05:17 AM

MySQL RPM
 
I still can't compile MySQL after installing the newer GCC RPM. Anyone else done it in RH 7.1, specifically using Apache Toolbox (although it fails when I do it by itself).

Cheers

glj

cinnix 07-24-2001 05:22 AM

what kind of error are you getting?

glj 07-24-2001 05:40 AM

Here's the tail of mysql-compile.log: -

mysqld.cc: In function `void *handle_connections_sockets (void *)':
/usr/include/tcpd.h:131: too many arguments to function `void sock_host
()'
mysqld.cc:2289: at this point in file
/usr/include/tcpd.h:69: too many arguments to function `int
hosts_access ()'
mysqld.cc:2290: at this point in file
/usr/include/tcpd.h:124: too many arguments to function `char
*eval_client ()'
mysqld.cc:2295: at this point in file
make[3]: *** [mysqld.o] Error 1
make[3]: Leaving directory `/root/Apachetoolbox-1.5.33/src/mysql-3.23.38/sql'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/Apachetoolbox-1.5.33/src/mysql-3.23.38/sql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Apachetoolbox-1.5.33/src/mysql-3.23.38'
make: *** [all-recursive-am] Error 2

cinnix 07-24-2001 05:50 AM

It seems that it is choking on a file from the tcp_wrappers package. Check to see if it needs updating.

glj 07-24-2001 05:55 AM

tcp wrapper is current to 7.6-18 (rpmfind lists that for RH 7.1)

cinnix 07-24-2001 06:14 AM

You may need a newer version of the tcp-wrappers since you are using a newer version of mysql.

you could also try this

Code:

rpm --verify tcp_wrappers
and see if you have any files that are having problems.

I am out of ideas here as to why that is failing. Hopefully someone else will be able to provide an answer.

glj 07-24-2001 06:18 AM

Unfortunatley, verify came up with nothing so I'm stuck for now!

Thanks anyway

glj

glj 07-24-2001 07:52 AM

I really should look at redhat.com more often! Went here: -

http://www.redhat.com/support/errata/RHSA-2001-003.html

downloaded all the rpms, installed (rpm -Uvh mysql*), and ran ATB, seems to be installing ok (it's gone past the mysql bit at least, it's configuring and compiling php at the mo).

Thanks for all the help anyway

glj

P.S. Happy Birthday cinnix

cinnix 07-24-2001 08:23 AM

thanks.

There are RPMS for PHP too. The ones from redhat 7.0 were no-good because they were not built with mysql support but the ones from 7.1 should be okay.


All times are GMT -5. The time now is 06:39 PM.