-   Linux - Software (
-   -   root owned applications won't start in KDE3 (

Jingle 08-07-2003 01:01 AM

root owned applications won't start in KDE3
I'm having a little problem

When I try to start a program like package management (or any other only by root startable program) as a normal user , I used to get a window asking for the root password . That window doesn't appear anymore.
I don't know what happened. I see that the application tries to launch but it just dies without any messages . :cry:

I don't want to login as root because I know that's dangerous , and I can mess up things easily , but once in a while I would like to do some root stuff ..
I use Red Hat 9 and KDE 3.1 what can I do to get the question for the root password back ?

glitt3r 08-07-2003 05:06 AM

I have no idea dude, did you do some googling yet ;) ?

Jingle 08-07-2003 05:28 AM

Yep i did but couldn't fing anything ..

DrOzz 08-07-2003 11:10 AM

that is pretty weird...i don't even know how you would go about typing in a string in google to get accurate results for that...hrmm just try little things cause i have absolutely no idea what the problem is or could be...
try this....
-) type the name of something that requires root privledges in the terminal, and see if any error messages are shown.....
an example of something to type that needs password input is:
since i see you use rh9, give that command a try and tell us what happens.

Jingle 08-07-2003 02:15 PM

I tried it , and nothing happens , absolutely nothing . Exactly the same as when I click the package management icon in kde .
This also happens when running gnome .
All the redhat-config-???? commands don't work

Are there any logfiles that can tell me (us) more perhaps ?
The var/log/messages file doesn't say anything , or any other file in the /var/log directory

DrOzz 08-07-2003 02:27 PM

i know the last thing you want to hear is to re-install, but i will look around later, and see if i can find anything...i never heard of such a thing, so i am speachless...
but i guess you can see if there is anything in your .xsession-errors file in your home directory.

also if your logged in as a normal user and you open a terminal and su to root and type password and then try to run something that needs to be ran as root, does it open?

Jingle 08-07-2003 03:06 PM


I was thinking : since when do I have this problem? and I remembered I've been trying to start kppp (to get on the internet ) and not wanting to keep typing the root password . So I gave /usr/sbin/kppp a setuid bit
but I also gave /usr/bin/kppp the setuid bit, but that was a link to /usr/bin/consolehelper and accidently that also got a setuid bit .
I removed the setuid bit from /usr/bin/consolehelper and that solved the problem .

Point proven , be carefull what you do when trying to do some root stuff .
Thanx very much for the help

All times are GMT -5. The time now is 11:42 PM.