LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-09-2005, 03:48 AM   #1
eddi.b
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
rh8 update from 3.0.5 to samba 3.0.11


have a samba 3.0.5 running on a redhat 8 (kernel 2.4.20) - i am now wanting to update to the 3.0.11 as we sometimes have connections lost with osx. thought an update would be the best thing to do.

problem 1: i cannot find a samba package for rh8
problem 2: when trying to install the package for rh9 i get the following error message:

error: Failed dependencies:
libcrypto.so.4 is needed by samba-3.0.11-1
libssl.so.4 is needed by samba-3.0.11-1

trying to find an openssl package greater than 0.9.6b-35.8 (which is installed) for rh8 is quite an act.

thanks for your help.

Last edited by eddi.b; 03-09-2005 at 03:56 AM.
 
Old 03-09-2005, 04:24 AM   #2
cain_eve
Member
 
Registered: Nov 2004
Posts: 93

Rep: Reputation: 15
when you configure samba
do
./configure -help
and it will automaticly tell you some parameters.
like : ./configure --with-openssl=/folder/to/your/openssl etc..
 
Old 03-09-2005, 04:40 AM   #3
eddi.b
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Original Poster
Rep: Reputation: 0
thanks for the quick reply.
as a newbie a am using webmin to install my rpms. when i try typing this into the console it cannot find the command.

but what you are trying to tell me is to change the folder to a new version of openssl?
 
Old 03-09-2005, 11:22 PM   #4
cain_eve
Member
 
Registered: Nov 2004
Posts: 93

Rep: Reputation: 15
sorry I made a mistake

please do ./configure --help

notice it is two - here

and I misunderstanding your problem last post. if you have an openssl version>require already install on your linux then do the above.
if not install the latest version.
and do make pkg-config notice this change.

Last edited by cain_eve; 03-09-2005 at 11:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
There's a way to update rh8 to rh9? Viceversa Red Hat 6 10-01-2003 05:29 PM
rh8 iptables update problem jeph Red Hat 1 08-30-2003 02:46 AM
RH8: update pooches x server- help me fix it bturnip Linux - Distributions 0 07-22-2003 05:27 PM
Can't update packages. RH8 tktim Linux - General 4 04-03-2003 12:06 AM
rh8.0 apr-get update errors pk21 Linux - Software 3 12-23-2002 07:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration