Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-05-2002, 03:38 PM   #1
LQ Newbie
Registered: Mar 2002
Location: Australia
Distribution: RedHat
Posts: 3

Rep: Reputation: 0
Question RH is not booting past pcmcia.

I have just installed RH 7.2 on an old Toshiba Satellite 2510CDS that I got very cheap.

The install went ok, no problems that I could see. But when I went to start for the first time is just stops loading at pcmcia.

I was hoping that someone may have come across this in the past and will be able to fill me in on an answer or workaround.

Thank you in advance.
Old 03-07-2002, 08:21 AM   #2
LQ Guru
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
Poking around, I didn't find anything on that exact model, but one minor version above is an install with a 2.4 kernel like RH 7.2's. RedHat is using the in-kernel PCMCIA driver package which suffers from two major problems: It is still in its infancy really, and it doesn't handle older hardware that well.

You should be able to boot with the boot floppy you made during install, find a boot disk on a floppy and take pcmcia out of Init, or simply re-install with no PCMCIA support (and make sure to do a custom install and choose the subsections Developer). Then you can compile pcmcia-cs, the older pcmcia card services package, as a separate entitiy, which is ironclad.

Or, you could install an older distro, which is the easiest way to get better performance out of older hardware.


Old 03-07-2002, 09:48 AM   #3
Senior Member
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,226

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
try sending the kernel arg
to your bootloader
once booted to the shell
type mount -oremount rw /
edit your /etc/inittab file to default to runlevel 1
reboot, you may have to FORCE it to reboot
remove init=/bin/bash from the bootloader
boot, run setup and uncheck pcmcia
edit /etc/inittab and reset default runlevel to whatever you want it to be
reboot and try again
hope this helps, cheers
p.s. plz email me if it works, i did this for resetting the domain name when it wouldn't get past sendmail at boot, cheers


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hanging up on PCMCIA booting mcar4446 Mandriva 2 11-22-2004 11:34 AM
Booting past DHCP without connection thomasjor Linux - Networking 3 09-29-2004 06:19 PM
How do i disable booting of pcmcia? Roitoy Red Hat 5 08-10-2004 08:31 AM
Booting from pcmcia dvdrom Craigwd Debian 4 04-03-2004 02:18 PM
Linux not booting past kernel startup jturck Linux - General 2 01-16-2004 09:20 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:57 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration